summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-25 10:28:03 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-02-25 10:28:03 +0100
commit7bf4ce4582cd2f9c5b30c547262c1c4a426c0b9b (patch)
treec6f9cc83feaaf685b7542a98e60bc24ea7c297b1 /gnu/packages/statistics.scm
parent06d01c610e3bee61e38a177aecda5982d5b338ae (diff)
parent92d8b4c9598ed32cdb6630433d5914c1ae8b7146 (diff)
Merge branch 'master' into gnome-team
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm145
1 files changed, 94 insertions, 51 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 8cfc9507ca..01d5e25a1a 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015-2023 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015-2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Vicente Vera Parra <vicentemvp@gmail.com>
;;; Copyright © 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017, 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
@@ -18,6 +18,7 @@
;;; Copyright © 2021 Frank Pursel <frank.pursel@gmail.com>
;;; Copyright © 2022 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2023 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
@@ -508,14 +509,14 @@ available, greatly increasing its breadth and scope.")
(define-public r-boot
(package
(name "r-boot")
- (version "1.3-28.1")
+ (version "1.3-29")
(source
(origin
(method url-fetch)
(uri (cran-uri "boot" version))
(sha256
(base32
- "0lzz08fpn80qzm197s4806hr6skanr3r3rlx6bx7zk4cripygkfl"))))
+ "1zgvy7n01qyxk52yhk43d7z7c36nr54z98vqwmjdlmhx4zyj0s7f"))))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/boot")
(synopsis "Bootstrap functions for R")
@@ -801,14 +802,14 @@ analysis.")
(define-public r-survival
(package
(name "r-survival")
- (version "3.5-7")
+ (version "3.5-8")
(source
(origin
(method url-fetch)
(uri (cran-uri "survival" version))
(sha256
(base32
- "0bi76kr5xkcs98r795lz9nvsj6zzxq0w6zn1938z0ffx5b9js3nm"))))
+ "1d0qvw4200mjldna9n0acis0fk8xj28wwzqb8c3d4537l92zivbi"))))
(build-system r-build-system)
(propagated-inputs
(list r-matrix))
@@ -997,19 +998,20 @@ OpenSSL should be used.")
(define-public r-estimability
(package
(name "r-estimability")
- (version "1.4.1")
+ (version "1.5")
(source (origin
(method url-fetch)
(uri (cran-uri "estimability" version))
(sha256
(base32
- "090i1xwdp4fwj8jr8nk13w49516lfkk5mq1w7l0lff9g8lgaynn6"))))
+ "0s6w8vnq0jc136d2mpf6pgg45rbxccrlsgdy89pgksnbaxhmyb5k"))))
(build-system r-build-system)
+ (native-inputs (list r-knitr))
(home-page "https://cran.r-project.org/web/packages/estimability")
(synopsis "Tools for assessing estimability of linear predictions")
- (description "Provides tools for determining estimability of linear
-functions of regression coefficients, and @code{epredict} methods that handle
-non-estimable cases correctly.")
+ (description "This package provides tools for determining estimability of
+linear functions of regression coefficients, and @code{epredict} methods that
+handle non-estimable cases correctly.")
(license license:gpl2+)))
(define-public r-labeling
@@ -1413,13 +1415,13 @@ evaluation (NSE) in R.")
(define-public r-dbi
(package
(name "r-dbi")
- (version "1.2.1")
+ (version "1.2.2")
(source (origin
(method url-fetch)
(uri (cran-uri "DBI" version))
(sha256
(base32
- "0w7dpp1zg8w0mback1mk0a0vp51hf4njmrxz1i3j1xq5b1jfyiz4"))))
+ "10d7sl9nk1gkkbinmvplyp2hg9zgxgs03llamrvbf4a5cnrs0mcd"))))
(build-system r-build-system)
(native-inputs
(list r-knitr))
@@ -1518,6 +1520,36 @@ it supports LaTeX and HTML output. Source code of other languages is
supported via Andre Simon's highlight package.")
(license license:gpl3+)))
+(define-public r-httpgd
+ (let ((commit "3f5f55822c4dce930155b91cedcfd4d483e3294e")
+ (revision "1"))
+ (package
+ (name "r-httpgd")
+ (version (git-version "2.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nx10/httpgd")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "14i7mhbv1vcz2886w9lii9zhgr4zhhc844349syb989nhhzg552n"))))
+ (properties `((upstream-name . "httpgd")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-asioheaders r-cpp11 r-unigd))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/nx10/httpgd")
+ (synopsis "'HTTP' Server Graphics Device")
+ (description
+ "This package provides a graphics device for R that is accessible via
+network protocols. This package was created to make it easier to embed live R
+graphics in integrated development environments and other applications. The
+included HTML/@code{JavaScript} client (plot viewer) aims to provide a better
+overall user experience when dealing with R graphics. The device
+asynchronously serves graphics via HTTP and @code{WebSockets}'.")
+ (license license:gpl2+))))
+
(define-public r-mime
(package
(name "r-mime")
@@ -3548,14 +3580,14 @@ statements.")
(define-public r-segmented
(package
(name "r-segmented")
- (version "2.0-2")
+ (version "2.0-3")
(source
(origin
(method url-fetch)
(uri (cran-uri "segmented" version))
(sha256
(base32
- "0ym5z2zngkqvs1cd7c3k16k9ipsli6xc6qp0nmr77va34d8v0n4q"))))
+ "1f89v6zbxwl6yhx3qi7wrr3rndnxfwaf49mygw357f7cf3i8ma77"))))
(build-system r-build-system)
(propagated-inputs (list r-mass r-nlme))
(home-page "https://cran.r-project.org/web/packages/segmented")
@@ -3793,13 +3825,13 @@ using the multicore functionality of the parallel package.")
"datatables-extensions/Buttons"))))
(package
(name "r-dt")
- (version "0.31")
+ (version "0.32")
(source (origin
(method url-fetch)
(uri (cran-uri "DT" version))
(sha256
(base32
- "11wwd76x1bk9aswi8w4bmvbf51j8hlmb5gsyqzfjdi6ihjkl4vwm"))
+ "0nvj2bc441b9h13085fa7q281f86lgx4k0d8lr64xgdpbmbvkl21"))
(modules '((guix build utils)
(ice-9 match)))
(snippet
@@ -4363,13 +4395,13 @@ persistent (on the file system).")
(define-public r-r-rsp
(package
(name "r-r-rsp")
- (version "0.45.0")
+ (version "0.46.0")
(source (origin
(method url-fetch)
(uri (cran-uri "R.rsp" version))
(sha256
(base32
- "192x8cvna1j0sx37xh3ha8bjjyx39pn5wnxzn5gs3z5j93a4d055"))))
+ "1frkgjc2mzvjnay8g5nky1bvxv60wvsypmmdj6mbsfjnzq7ni7qs"))))
(properties `((upstream-name . "R.rsp")))
(build-system r-build-system)
(arguments
@@ -6776,8 +6808,8 @@ Java package that provides routines for various statistical distributions.")
(license license:gpl2+)))
(define-public emacs-ess
- (let ((commit "3691ecc642eab5d016887e42699648e0eeeef566")
- (version "18.10.2")
+ (let ((commit "ab2faeca1ba6c456333312c58f58ef9e5ef4aa8b")
+ (version "24.01.1")
(revision "1"))
(package
(name "emacs-ess")
@@ -6789,7 +6821,7 @@ Java package that provides routines for various statistical distributions.")
(url "https://github.com/emacs-ess/ESS")
(commit commit)))
(sha256
- (base32 "19p8djsbgvahpsx1w8i6h3qvpbdr4isjwm3wi82yk2648ri0qsq1"))
+ (base32 "0jfdfqpa3x1zm65cllkzhqir057xd3hxi4z2ddii1i26zy56iikf"))
(file-name (git-file-name name version))
(modules '((guix build utils)))
(snippet
@@ -6807,9 +6839,6 @@ Java package that provides routines for various statistical distributions.")
;; Stop install-info from trying to update the info directory.
(substitute* "doc/Makefile"
((".*/dir.*") ""))
- ;; Fix r-help-mode test.
- (substitute* "test/ess-test-r.el"
- (("\\(equal ess-help-object \"plot.default\")") "t"))
;; Avoid generating ess-autoloads.el twice.
(substitute* "Makefile"
(("all: lisp doc etc autoloads")
@@ -6839,9 +6868,6 @@ Java package that provides routines for various statistical distributions.")
#~(modify-phases %standard-phases
(delete 'configure)
(add-before 'check 'skip-failing-tests
- ;; The command-without-trailing-newline-test and other
- ;; tests fail for unknown reasons (see:
- ;; https://github.com/emacs-ess/ESS/issues/1272).
(lambda _
(let-syntax
((disable-tests
@@ -6853,22 +6879,7 @@ Java package that provides routines for various statistical distributions.")
(((string-append "^\\(ert-deftest " test-name ".*")
all)
(string-append all "(skip-unless nil)\n"))
- ...))))
- (disable-etests ;different test syntax
- (syntax-rules ()
- ((_ file ())
- (syntax-error "test names list must not be empty"))
- ((_ file (test-name ...))
- (emacs-batch-edit-file file
- '(progn
- (mapc (lambda (test)
- (goto-char (point-min))
- (search-forward
- (format "etest-deftest %s " test))
- (beginning-of-line)
- (kill-sexp))
- (list test-name ...))
- (basic-save-buffer)))))))
+ ...)))))
(disable-tests (list "test/ess-test-inf.el"
"test/ess-test-r.el")
("ess--derive-connection-path"
@@ -6878,15 +6889,10 @@ Java package that provides routines for various statistical distributions.")
"ess-r-load-ESSR-github-fetch-no"
"ess-r-load-ESSR-github-fetch-yes"
"ess-set-working-directory-test"
- "ess-test-r-startup-directory"))
- (disable-etests "test/ess-test-r-eval.el"
- ("ess-r-eval-ns-env-roxy-tracebug-test"
- "ess-r-eval-sink-freeze-test"))
- (disable-etests
- "test/ess-test-inf.el"
- ("command-without-trailing-newline-test")))))
+ "ess-test-r-startup-directory")))))
(replace 'check
- (lambda _ (invoke "make" "test")))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "make" "test"))))))))
(native-inputs (list perl r-roxygen2 texinfo))
(inputs (list emacs-minimal r-minimal))
(propagated-inputs (list emacs-julia-mode))
@@ -7775,3 +7781,40 @@ weighting schemes.")
statistical summary in arrays and enumerables.")
(home-page "https://github.com/mrkn/enumerable-statistics")
(license license:expat)))
+
+(define-public python-pgmpy
+ (package
+ (name "python-pgmpy")
+ (version "0.1.24")
+ (source
+ (origin
+ (method git-fetch) ;pypi package does not include test data
+ (uri (git-reference
+ (url "https://github.com/pgmpy/pgmpy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fvzh6v0yhgdryczamvzhfy2ymywkh0ssx4rl47xnfvi43hnij90"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-daft
+ python-joblib
+ python-networkx
+ python-numpy
+ python-opt-einsum
+ python-pandas
+ python-pyparsing
+ python-pytorch
+ python-scikit-learn
+ python-scipy
+ python-statsmodels
+ python-tqdm))
+ (native-inputs (list python-mock
+ python-pytest))
+ (home-page "https://github.com/pgmpy/pgmpy")
+ (synopsis "Probabilistic Graphical Models library")
+ (description "This package provides a library for Probabilistic
+Graphical Models. It can be used for learning (Structure and Parameter),
+inference (Probabilistic and Causal), and simulations in Bayesian
+Networks.")
+ (license license:expat)))