summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-28 13:31:42 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:28:38 +0100
commit00e10c6e674f0f292d5821bc4a513d48f4d1d164 (patch)
treea18caf2411dfb399fb00960188cac19a6c7b43d7 /gnu/packages/statistics.scm
parentf3b98f4fec43c951a9e28c67561395992bf190a7 (diff)
gnu: Remove python-setuptools and python2-setuptools from inputs (part 3)
This patch contains the changes where setuptools are used in an inherited package and removing this input keeps the need for inheriting the package. * gnu/packages/bioinformatics.scm (python2-biom-format): Remove python-setuptools respective python2-setuptools from [inputs], [native-inputs] and [propagated-inputs] in Python 2 packages inheriting from a Python 3 package. * gnu/packages/python.scm (python2-pytest-mock, python2-oauthlib, python2-seaborn, python2-tornado, python2-terminado, python2-rauth, python2-anyjson, python2-amqp, python2-kombu, python2-billiard, python2-celery, python2-jellyfish, python2-binaryornot, python2-natsort, python2-graphene): Likewise. * gnu/packages/statistics.scm (python2-statsmodels): Likewise.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 700a8957cc..a19d6000d4 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1487,10 +1487,7 @@ inference for statistical models.")
("python2-scipy" ,python2-scipy)
("python2-pandas" ,python2-pandas)
("python2-patsy" ,python2-patsy)
- ("python2-matplotlib" ,python2-matplotlib)))
- (native-inputs
- `(("python2-setuptools" ,python2-setuptools)
- ,@(package-native-inputs stats))))))
+ ("python2-matplotlib" ,python2-matplotlib))))))
(define-public r-coda
(package