summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-31 15:27:56 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-03 14:31:51 +0200
commit7e10056b6bea8d3c43cff1948073d1e24c63e197 (patch)
tree0ff48a8d9a14f470b961a67022e234d34f15f464 /gnu/packages/statistics.scm
parentea69e2f853f8b6ffb490310920db29de829751fb (diff)
gnu: Add r-plyr.
* gnu/packages/statistics.scm (r-plyr): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 0da3b82c8e..6ba75b7850 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -291,3 +291,26 @@ about Rcpp is provided by several vignettes included in this package, via the
and Francois (2011, JSS), and the book by Eddelbuettel (2013, Springer); see
'citation(\"Rcpp\")' for details on these last two.")
(license license:gpl2+)))
+
+(define-public r-plyr
+ (package
+ (name "r-plyr")
+ (version "1.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cran/src/contrib/plyr_"
+ version ".tar.gz"))
+ (sha256
+ (base32 "06v4zxawpjz37rp2q2ii5q43g664z9s29j4ydn0cz3crn7lzl6pk"))))
+ (build-system r-build-system)
+ (native-inputs `(("r-rcpp" ,r-rcpp)))
+ (home-page "http://had.co.nz/plyr")
+ (synopsis "Tools for Splitting, Applying and Combining Data")
+ (description
+ "Plyr is a set of tools that solves a common set of problems: you need to
+break a big problem down into manageable pieces, operate on each piece and
+then put all the pieces back together. For example, you might want to fit a
+model to each spatial location or time point in your study, summarise data by
+panels or collapse high-dimensional arrays to simpler summary statistics.")
+ (license license:expat)))