summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-31 15:36:03 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-03 14:31:51 +0200
commit9ca731baf196d41cfbbd07cb85d8fd46b7fa4b40 (patch)
tree1d2e08d90aa8125e1f43a0373462a5d415ab1f76 /gnu/packages/statistics.scm
parentd5cd5c1568f95b6919f325c41fe37859e5abd2b4 (diff)
gnu: Add r-reshape2.
* gnu/packages/statistics.scm (r-reshape2): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index ed550ede82..5b662a1d4e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -406,3 +406,26 @@ positions) are consistent, all functions deal with \"NA\"'s and zero length
vectors in the same way, and the output from one function is easy to feed into
the input of another.")
(license license:gpl2+)))
+
+(define-public r-reshape2
+ (package
+ (name "r-reshape2")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cran/src/contrib/reshape2_"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0hl082dyk3pk07nqprpn5dvnrkqhnf6zjnjig1ijddxhlmsrzm7v"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-plyr" ,r-plyr)
+ ("r-rcpp" ,r-rcpp)
+ ("r-stringr" ,r-stringr)))
+ (home-page "https://github.com/hadley/reshape")
+ (synopsis "Flexibly reshape data: a reboot of the \"reshape\" package")
+ (description
+ "Reshape2 is an R library to flexibly restructure and aggregate data
+using just two functions: melt and dcast (or acast).")
+ (license license:expat)))