summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2016-12-27 21:58:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-12-29 19:54:59 +0100
commit2fd261a37a4fc28a65b4d2ebfc897f15e6ff1947 (patch)
tree4000e63a6e8498b7d0067ad811fe08f830376168 /gnu/packages/statistics.scm
parent294304169a5ecc6efbb581102b871c4646c34966 (diff)
gnu: Add r-statmod.
* gnu/packages/statistics.scm (r-statmod): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 22485a8263..e1523f7d90 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3896,3 +3896,29 @@ representation of R code.")
such that the arrangement of points within a category reflects the density of
data at that region, and avoids over-plotting.")
(license license:gpl2+)))
+
+(define-public r-statmod
+ (package
+ (name "r-statmod")
+ (version "1.4.27")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "statmod" version))
+ (sha256
+ (base32
+ "14yilq9d3z20hig4rs8bjqyydw3dfx90mhmzvw9w8p16h0s595sn"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/statmod")
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (synopsis "Statistical modeling")
+ (description
+ "This package provides a collection of algorithms and functions to aid
+statistical modeling. It includes growth curve comparisons, limiting dilution
+analysis (aka ELDA), mixed linear models, heteroscedastic regression,
+inverse-Gaussian probability calculations, Gauss quadrature and a secure
+convergence algorithm for nonlinear models. It also includes advanced
+generalized linear model functions that implement secure convergence,
+dispersion modeling and Tweedie power-law families.")
+ ;; Statmod is distributed under either license
+ (license (list license:gpl2 license:gpl3))))