summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-24 14:55:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-28 22:43:15 +0100
commit58612fd2c869995fd18ed915d4d240b173079e73 (patch)
tree30aaab31c894348684e0ca9b6f6ed8e5fa1a3659 /gnu/packages/statistics.scm
parente48ddb96282cd231e4aed2255f6b918901a71922 (diff)
gnu: Add r-rematch.
* gnu/packages/statistics.scm (r-rematch): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 700a8957cc..612ea530d8 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3272,6 +3272,26 @@ noncentral hypergeometric distribution (also called extended hypergeometric
distribution).")
(license license:gpl3+)))
+(define-public r-rematch
+ (package
+ (name "r-rematch")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rematch" version))
+ (sha256
+ (base32
+ "0y3mshvpvz9csmq8hk8jbabx4nxlv5sckvfzvm6920ndg34xw2d4"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/MangoTheCat/rematch")
+ (synopsis "Match regular expressions with a nicer API")
+ (description
+ "This package provides a small wrapper on @code{regexpr} to extract the
+matches and captured groups from the match of a regular expression to a
+character vector.")
+ (license license:expat)))
+
(define-public r-rpart
(package
(name "r-rpart")