summaryrefslogtreecommitdiff
path: root/gnu/packages/statistics.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-10-26 08:42:02 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-10-26 09:28:07 +0200
commit557a4b8e61e42e1d2b9036705cbb419b81385569 (patch)
treee76af0e9392e97cc805339aab14e0ad5df85b508 /gnu/packages/statistics.scm
parentf9875807e89d7aa94428eb21374b5bcf42494c18 (diff)
gnu: Add r-kernsmooth.
* gnu/packages/statistics.scm (r-kernsmooth): New variable.
Diffstat (limited to 'gnu/packages/statistics.scm')
-rw-r--r--gnu/packages/statistics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 959251d84c..2a42153df6 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -3278,6 +3278,30 @@ conversion of R objects to LaTeX code, and recoding variables.")
framework, with additional code inspection and report generation tools.")
(license license:gpl2+)))
+(define-public r-kernsmooth
+ (package
+ (name "r-kernsmooth")
+ (version "2.23-15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "KernSmooth" version))
+ (sha256
+ (base32
+ "1xhha8kw10jv8pv8b61hb5in9qiw3r2a9kdji3qlm991s4zd4wlb"))))
+ (properties `((upstream-name . "KernSmooth")))
+ (build-system r-build-system)
+ (inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "http://cran.r-project.org/web/packages/KernSmooth")
+ (synopsis "Functions for kernel smoothing")
+ (description
+ "This package provides functions for kernel smoothing (and density
+estimation) corresponding to the book: Wand, M.P. and Jones, M.C. (1995)
+\"Kernel Smoothing\".")
+ ;; Unlimited use and distribution
+ (license (license:non-copyleft "file://LICENSE.note"))))
+
(define-public r-zoo
(package
(name "r-zoo")