summaryrefslogtreecommitdiff
path: root/gnu/packages/stenography.scm
diff options
context:
space:
mode:
authorParnikkapore <poomklao@yahoo.com>2023-01-02 08:08:03 +0700
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-03 21:56:53 +0100
commitf9cd9ed8691ca0c8112c32ea85304c09e1845cfa (patch)
tree81e2cbc13a6c628d488e0f5fedee406db017abf5 /gnu/packages/stenography.scm
parenta6b8d4e336c2a3aa7270086494228f6987076601 (diff)
gnu: plover: Wrap so that icons can be found.
* gnu/packages/stenography.scm (plover): Wrap and add qtsvg to QT_PLUGIN_PATH This is needed for the icons in Plover's UI to appear. [inputs]: Add BASH-MINIMAL. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/stenography.scm')
-rw-r--r--gnu/packages/stenography.scm32
1 files changed, 20 insertions, 12 deletions
diff --git a/gnu/packages/stenography.scm b/gnu/packages/stenography.scm
index 504dfc990f..56930dd37a 100644
--- a/gnu/packages/stenography.scm
+++ b/gnu/packages/stenography.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2020, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2023 Parnikkapore <poomklao@yahoo.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,7 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages qt)
#:use-module (gnu packages check)
#:use-module (gnu packages libusb)
@@ -55,15 +57,15 @@
(package
(name "plover")
(version "4.0.0.dev12")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/openstenoproject/plover")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0vk6nh2gpn7f7rv2spi2a7n3m0d9kaan6r22mx3vwxprpbvrkbm8"))))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/openstenoproject/plover")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0vk6nh2gpn7f7rv2spi2a7n3m0d9kaan6r22mx3vwxprpbvrkbm8"))))
(build-system python-build-system)
(arguments
(list
@@ -77,8 +79,13 @@
"-p" "xvfb"
"test"
;; FIXME: Ignore failing test.
- "--ignore"
- "test/gui_qt/test_dictionaries_widget.py")))))))
+ "--ignore" "test/gui_qt/test_dictionaries_widget.py"))))
+ ;; Ensure that icons are found at runtime.
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs #:allow-other-keys)
+ (wrap-program (string-append #$output "/bin/plover")
+ `("QT_PLUGIN_PATH" prefix
+ ,(list (search-input-directory inputs "/lib/qt5/plugins/")))))))))
(native-inputs
(list python-babel
python-mock
@@ -86,7 +93,8 @@
python-pytest-qt
python-pytest-xvfb))
(inputs
- (list python-appdirs
+ (list bash-minimal
+ python-appdirs
python-dbus
python-hidapi
python-plover-stroke