summaryrefslogtreecommitdiff
path: root/gnu/packages/suckless.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2023-01-12 19:14:38 -0500
committerLeo Famulari <leo@famulari.name>2023-01-13 00:46:13 -0500
commit789d73234d5b6bbd83bb054146d5bbd1d374d51a (patch)
tree366f7a4bd128fcba730f25eff8d706e5d19b013a /gnu/packages/suckless.scm
parentfabc048fcfb6010d8c8b16fa1a82c051a20559dc (diff)
gnu: sent: Install some more useful documentation.
* gnu/packages/suckless.scm (sent)[arguments]: Install the README.md in a new 'install-doc' phase.
Diffstat (limited to 'gnu/packages/suckless.scm')
-rw-r--r--gnu/packages/suckless.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/suckless.scm b/gnu/packages/suckless.scm
index bb55afa412..8844482cc9 100644
--- a/gnu/packages/suckless.scm
+++ b/gnu/packages/suckless.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;; Copyright © 2016, 2017 Nikita <nikita@n0.is>
;;; Copyright © 2015 Dmitry Bogatov <KAction@gnu.org>
-;;; Copyright © 2015 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2015, 2023 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -547,7 +547,13 @@ point surf to another URI by setting its XProperties.")
(add-before 'build 'patch-farbfeld
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "config.def.h"
- (("2ff") (search-input-file inputs "/bin/2ff"))))))
+ (("2ff") (search-input-file inputs "/bin/2ff")))))
+ (add-after 'install 'install-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc/" ,name "-"
+ ,(package-version this-package))))
+ (install-file "README.md" doc)))))
#:tests? #f ;no test suite
#:make-flags
(let ((pkg-config (lambda (flag)