summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-11-08 17:05:37 -0500
committerLeo Famulari <leo@famulari.name>2017-11-08 17:24:01 -0500
commit52ff28e4aab21335d40dc63b69113c867c71c845 (patch)
treea2ef1c9457da1bb8bdbbd1bb4b199df20473483a /gnu/packages/syncthing.scm
parent4cf6827de315e0d4d8e0540cd3e9327399e925d9 (diff)
gnu: Add go-github-com-zillode-notify.
* gnu/packages/syncthing.scm (go-github-com-zillode-notify): New variable.
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 46981d14a8..94ec693cb6 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1867,3 +1867,29 @@ cipher used in the Chinese National Standard for Wireless LAN WAPI (Wired
Authentication and Privacy Infrastructure).")
(home-page "https://github.com/tjfoc/gmsm")
(license asl2.0))))
+
+(define-public go-github-com-zillode-notify
+ (let ((commit "54e3093eb7377fd139c4605f475cc78e83610b9d")
+ (revision "0"))
+ (package
+ (name "go-github-com-zillode-notify")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zillode/notify")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xmj0bh15hqbzq5qsbi2nb2lihl1pqdh1vwalwmxywnda3w68xj6"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/zillode/notify"))
+ (propagated-inputs
+ `(("go-golang-org-x-sys-unix" ,go-golang-org-x-sys-unix)))
+ (synopsis "Filesystem event notification library")
+ (description "This package provides @code{notify}, a filesystem event
+notification library in Go.")
+ (home-page "https://github.com/zillode/notify")
+ (license expat))))