summaryrefslogtreecommitdiff
path: root/gnu/packages/syncthing.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-24 21:49:35 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-24 21:49:35 +0000
commit40d697a30140321865f2c3fff28711d543673474 (patch)
treec2e1863d847aeb9d59c8e97af562e217a0919da5 /gnu/packages/syncthing.scm
parentdb340ca57a7991b0b2c8c4c5f5c28e218b2ad700 (diff)
gnu: go-github-com-lib-pq: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-lib-pq): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. * gnu/packages/databases.scm: Remvoe (gnu packages syncthing). Change-Id: I0f2f9c2366fd47b7167044d76f8c2c67a2f65544
Diffstat (limited to 'gnu/packages/syncthing.scm')
-rw-r--r--gnu/packages/syncthing.scm25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index ebbf8b82bb..779e921d65 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -424,31 +424,6 @@ address of the default LAN gateway.")
(home-page "https://github.com/jackpal/gateway")
(license bsd-3)))
-(define-public go-github-com-lib-pq
- (package
- (name "go-github-com-lib-pq")
- (version "1.2.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lib/pq")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "08j1smm6rassdssdks4yh9aspa1dv1g5nvwimmknspvhx8a7waqz"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/lib/pq"
- ;; The tests seem to fail without access to the network or a running
- ;; Postgres instance.
- #:tests? #f))
- (synopsis "Golang Postgres driver for Go's database/sql")
- (description "This package provides a pure Go Postgres driver for Go's
-database/sql package.")
- (home-page "https://github.com/lib/pq")
- (license expat)))
-
(define-public go-github-com-oschwald-geoip2-golang
(package
(name "go-github-com-oschwald-geoip2-golang")