summaryrefslogtreecommitdiff
path: root/gnu/packages/syndication.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-11-06 11:14:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-11-06 13:54:55 +0200
commit56255c3e813b4b7d7f50306463d63be6fc9d720d (patch)
tree46c7461a20488ba7ca18fab22e61467b14d55a80 /gnu/packages/syndication.scm
parent072fd1124a8081753ce92ed3a2a57489d24c5e4a (diff)
gnu: newsboat: Only build documentation on supported systems.
* gnu/packages/syndication.scm (newsboat)[inputs]: Only use asciidoctor on supported platforms. [arguments]: When asciidoctor isn't present add a phase to skip building the documentation.
Diffstat (limited to 'gnu/packages/syndication.scm')
-rw-r--r--gnu/packages/syndication.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index c30d16c870..95971b6e64 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -238,7 +238,10 @@ cards.")
("openssl" ,openssl)
("pkg-config" ,pkg-config)
;; For building documentation.
- ("asciidoctor" ,ruby-asciidoctor)))
+ ,@(if (member (%current-system)
+ (package-transitive-supported-systems ruby-asciidoctor))
+ `(("asciidoctor" ,ruby-asciidoctor))
+ `())))
(inputs
(list curl
json-c
@@ -277,6 +280,15 @@ cards.")
("rust-section-testing" ,rust-section-testing-0.0))
#:phases
(modify-phases %standard-phases
+ ,@(if (not (assoc-ref inputs "asciidoctor"))
+ `((add-after 'unpack 'dont-use-asciidoctor
+ (lambda _
+ (substitute* "config.sh"
+ ((".*asciidoctor.*") ""))
+ (substitute* "Makefile"
+ (("^doc:.*") "doc:\n")
+ (("install-podboat install-docs") "install-podboat")))))
+ '())
(add-after 'configure 'dont-vendor-self
(lambda* (#:key vendor-dir #:allow-other-keys)
;; Don't keep the whole tarball in the vendor directory