summaryrefslogtreecommitdiff
path: root/gnu/packages/task-management.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2024-03-23 11:21:08 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-03-24 11:48:53 +0100
commitf367047e9574ca8dd30ae8dc36ab1e783e2af71b (patch)
treebab5cea11e5eda89804709959586fa71db454956 /gnu/packages/task-management.scm
parent51f59e24266271c058eeb03ce600b534f07f9dcc (diff)
gnu: todoman: Fix tests.
* gnu/packages/task-management.scm (todoman) [#:phases] <check>: Load the `ci' hypothesis profile provided by upstream. Change-Id: I2ea01f8c424a50cd617303f8338f92563e7b0204 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/task-management.scm')
-rw-r--r--gnu/packages/task-management.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/task-management.scm b/gnu/packages/task-management.scm
index aac643799f..96df50d747 100644
--- a/gnu/packages/task-management.scm
+++ b/gnu/packages/task-management.scm
@@ -453,7 +453,8 @@ on arbitrary tasks. All the time data is saved in files residing in the
(replace 'check
(lambda* (#:key inputs outputs tests? #:allow-other-keys)
(when tests?
- (invoke "pytest" "-vv" "tests" "-k"
+ (invoke "pytest" "--hypothesis-profile=ci"
+ "-vv" "tests" "-k"
(string-append
;; Test expects wrong output string.
"not test_bad_start_date "