summaryrefslogtreecommitdiff
path: root/gnu/packages/telegram.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2022-09-20 23:34:51 +0800
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-21 06:26:57 +0200
commit425e4f6fcd0d844e44a9af7214906812531ec87f (patch)
tree4cceefa0bd48d4683ef6bd826507d57166efab96 /gnu/packages/telegram.scm
parent5ca7ec92f55c3b878dfbae01da928402847a59f3 (diff)
gnu: telegram-desktop: Delete trailing #t.
* gnu/packages/telegram.scm (telegram-desktop)[source]: Delete trailing #t. [arguments]<#:phases>: Likewise. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/telegram.scm')
-rw-r--r--gnu/packages/telegram.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/telegram.scm b/gnu/packages/telegram.scm
index ae1b727df7..08a72d2e0f 100644
--- a/gnu/packages/telegram.scm
+++ b/gnu/packages/telegram.scm
@@ -292,8 +292,7 @@ Telegram project, for its use in telegram desktop client.")
(for-each delete-file-recursively
(lset-difference string=?
(scandir ".")
- (cons* "." ".." keep))))
- #t)))))
+ (cons* "." ".." keep)))))))))
(build-system qt-build-system)
(arguments
`(#:tests? #f ; No target
@@ -322,8 +321,7 @@ Telegram project, for its use in telegram desktop client.")
(modify-phases %standard-phases
(add-after 'unpack 'make-writable
(lambda _
- (for-each make-file-writable (find-files "."))
- #t))
+ (for-each make-file-writable (find-files "."))))
(add-after 'make-writable 'copy-inputs
(lambda* (#:key inputs outputs #:allow-other-keys)
(for-each
@@ -350,14 +348,10 @@ Telegram project, for its use in telegram desktop client.")
("Telegram/lib_waylandshells" ,(assoc-ref inputs "lib-waylandshells-source"))
("Telegram/lib_webrtc" ,(assoc-ref inputs "lib-webrtc-source"))
("Telegram/lib_webview" ,(assoc-ref inputs "lib-webview-source"))
- ("Telegram/ThirdParty/tgcalls"
- ,(assoc-ref inputs "tgcalls-source"))))
- #t))
+ ("Telegram/ThirdParty/tgcalls" ,(assoc-ref inputs "tgcalls-source"))))))
(add-before 'configure 'patch-cxx-flags
(lambda _
- (substitute* "cmake/options_linux.cmake"
- (("class-memaccess") "all"))
- #t))
+ (substitute* "cmake/options_linux.cmake" (("class-memaccess") "all"))))
(add-after 'install 'glib-or-gtk-compile-schemas
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
(add-after 'glib-or-gtk-compile-schemas 'glib-or-gtk-wrap