summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorSuhail <suhail@bayesians.ca>2023-10-20 19:51:35 +0000
committerLudovic Courtès <ludo@gnu.org>2023-11-22 16:51:45 +0100
commit6d7eb7de7d09e2964b10537bdcf7fde929421324 (patch)
treeaa1c08da87d8b57d45ab365c88367b369d8e82d2 /gnu/packages/terminals.scm
parentc39c89c11eb58b825ab4adbe53165b20b6f1e6f4 (diff)
gnu: tilda: Add version 1.6-alpha with D-Bus support
* gnu/packages/terminals.scm (tilda-dbus): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index adb5e223e7..ad9fba23a4 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -189,6 +189,29 @@ configurable through a graphical wizard.")
(home-page "https://github.com/lanoxx/tilda")
(license license:gpl2+)))
+(define-public tilda-dbus
+ (package
+ (inherit tilda)
+ (name "tilda")
+ (version "1.6-alpha")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lanoxx/tilda")
+ (commit "51a980a55ad6d750daa21d43a66d44577dad277b")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pdarmlxkap9v689s88b89l5hi4vspsrrysh7pbm9rhdjmzk5m2c"))))
+ (synopsis "GTK+-based drop-down terminal with experimental D-Bus support")
+ (description
+ "Tilda is a terminal emulator similar to normal terminals like
+gnome-terminal (GNOME) or Konsole (KDE), with the difference that it drops down
+from the edge of a screen when a certain configurable hotkey is pressed. This
+is similar to the built-in consoles in some applications. Tilda is highly
+configurable through a graphical wizard. This version enables D-Bus support
+which is necessary for using Tilda on Wayland.")))
+
(define-public termite
(package
(name "termite")