summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorJaeme Sifat <jaeme@runbox.com>2023-10-27 22:13:41 -0400
committerChristopher Baines <mail@cbaines.net>2023-11-03 09:59:41 +0000
commit809f461ec112395228acd8e84812f5fe80126dad (patch)
tree210f2a01e21d5ea5317010debe2b6dc164fb716b /gnu/packages/terminals.scm
parentada7e0d04286d800197cc06752ea1b4a0f8a91d0 (diff)
gnu: foot: Update to 1.16.2.
* gnu/packages/terminals.scm (foot): Update to 1.16.2. [arguments]: Use gexps. Change-Id: I0615f6251a918a572369c05b126853f79e9fca4c Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 810c361705..adb5e223e7 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2023 Aaron Covrig <aaron.covrig.us@ieee.org>
;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -834,33 +835,34 @@ eye-candy, customizable, and reasonably lightweight.")
(define-public foot
(package
(name "foot")
- (version "1.15.3")
+ (version "1.16.2")
(home-page "https://codeberg.org/dnkl/foot")
- (source (origin
- (method git-fetch)
- (uri (git-reference (url home-page) (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1a224i2i7qk170kf2rzyxqcv3lnx9f548lwa37jgjr7i339x4zwf"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "00wac8li1ac8ncmnlqvz3xnr5pi8gj4v3v341n0h2zzaayv9ngw5"))))
(build-system meson-build-system)
(arguments
- `(;; Using a "release" build is recommended both for performance, and
- ;; also to address a GCC 10 issue when doing PGO builds.
- #:build-type "release"
- ;; Enable LTO as recommended by INSTALL.md.
- #:configure-flags '("-Db_lto=true")))
- (native-inputs
- (list ncurses ;for 'tic'
- pkg-config scdoc wayland-protocols))
+ (list
+ ;; Using a "release" build is recommended both for performance, and
+ ;; also to address a GCC 10 issue when doing PGO builds.
+ #:build-type "release"
+ ;; Enable LTO as recommended by INSTALL.md.
+ #:configure-flags #~'("-Db_lto=true")))
+ (native-inputs (list ncurses ;for 'tic'
+ pkg-config scdoc wayland-protocols))
(native-search-paths
;; FIXME: This should only be located in 'ncurses'. Nonetheless it is
;; provided for usability reasons. See <https://bugs.gnu.org/22138>.
(list (search-path-specification
(variable "TERMINFO_DIRS")
(files '("share/terminfo")))))
- (inputs
- (list fcft libxkbcommon wayland))
+ (inputs (list fcft libxkbcommon wayland))
(synopsis "Wayland-native terminal emulator")
(description
"@command{foot} is a terminal emulator for systems using the Wayland