summaryrefslogtreecommitdiff
path: root/gnu/packages/terminals.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-10-16 02:00:02 +0200
commitc585582fc1c0a8acaaaf78d6b898e4eae461dce4 (patch)
tree326600341efa75b8eaa601d67603a1a00fa441de /gnu/packages/terminals.scm
parentfea40a0cebaceec6661a49c8acfbf338852b3af6 (diff)
gnu: python-curtsies: Update to 0.4.0.
* gnu/packages/terminals.scm (python-curtsies): Update to 0.4.0. [propagated-inputs]: Replace python-blessings with python-blessed. [native-inputs]: Remove python-mock.
Diffstat (limited to 'gnu/packages/terminals.scm')
-rw-r--r--gnu/packages/terminals.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 8f2ac9974c..04b2dcbc8b 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -1097,14 +1097,13 @@ than a terminal.")
(define-public python-curtsies
(package
(name "python-curtsies")
- (version "0.3.5")
+ (version "0.4.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "curtsies" version))
(sha256
- (base32
- "1g8dwafx4vx06isjkn28r3cwb0hw1bv67lgygaz34yk66lrzz1x5"))))
+ (base32 "1zj284kacv0d10ab3amkkx37hcciylkqympsksi9bwzy6g7fyafb"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1113,9 +1112,9 @@ than a terminal.")
(lambda _
(invoke "nosetests" "-v"))))))
(propagated-inputs
- (list python-blessings python-cwcwidth))
+ (list python-blessed python-cwcwidth))
(native-inputs
- (list python-mock python-pyte python-nose))
+ (list python-pyte python-nose))
(home-page "https://github.com/bpython/curtsies")
(synopsis "Library for curses-like terminal interaction with colored
strings")