summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:53:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:31 +0200
commit351e6454aa716a1d4bca51c60cb699cc81bdbf22 (patch)
tree0a1056f48dcd1083682b7ab2fee7a9cb27314752 /gnu/packages/tex.scm
parent9dbc4e34a1507c768e2f3cb57e6082c70024ae4d (diff)
gnu: Add texlive-synproof.
* gnu/packages/tex.scm (texlive-synproof): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 67577bb233..54bea663fa 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6576,6 +6576,26 @@ expressions, as well as graphical output from the @code{sympy} plotting
module (or from Matplotlib).")
(license license:gpl2)))
+(define-public texlive-synproof
+ (package
+ (name "texlive-synproof")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/synproof/" "tex/latex/synproof/")
+ (base32
+ "02r0ld3lcxvjhij4lffx9kljmbv6fvz10x59bjvinqfbmmfmm58m")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/synproof")
+ (synopsis "Easy drawing of syntactic proofs")
+ (description
+ "The package provides a set of macros based on PSTricks that will enable
+you to draw syntactic proofs easily (inspired by the Gamut books). Very few
+commands are needed, however fine tuning of the various
+parameters (dimensions) can still be achieved through key=value pairs.")
+ (license license:lppl)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")