summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 17:00:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:40 +0200
commit52e9ee84afd978cdcddca3676ccfee93d861cdeb (patch)
treece7a7063dff877cfbb6935888b711184ad7d5b04 /gnu/packages/tex.scm
parent3517d572d0399f5bf5a603b13bcd8999908f9616 (diff)
gnu: Add texlive-yquant.
* gnu/packages/tex.scm (texlive-yquant): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 8d4de445ae..dbe75a0216 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6990,6 +6990,30 @@ mathematical symbols for the representations of groups, providing two macros,
@code{\\yng(1)} and @code{\\young(1)} to generate the whole Young-Tableau.")
(license license:lppl1.0+)))
+(define-public texlive-yquant
+ (package
+ (name "texlive-yquant")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/yquant/" "tex/latex/yquant/")
+ (base32
+ "1ibrll05slxh1xin6zb14nwic4a86gkpk60k8dzgf184l3kkv8lj")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/yquant")
+ (synopsis "Typesetting quantum circuits in a human-readable language")
+ (description
+ "This LaTeX package allows to quickly draw quantum circuits. It bridges
+the gap between the two groups of packages that already exist: those that use
+a logic-oriented custom language, which is then translated into TeX by means
+of an external program; and the pure TeX versions that mainly provide some
+macros to allow for an easier input. @code{yquant} introduces a logic
+oriented language and thus brings the best of both worlds together. It builds
+on and interacts with TikZ, which brings an enourmous flexibility for
+customization of individual circuit.")
+ (license license:lppl1.3c)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")