summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:51:43 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:29 +0200
commit6f2764135ebe2fbe56553cdd584ddeb360dc8b87 (patch)
treea975f683e584436818d6196d679d04875452de7d /gnu/packages/tex.scm
parent704bde84ec27383773f0b941c56664b44f3553dc (diff)
gnu: Add texlive-struktex.
* gnu/packages/tex.scm (texlive-struktex): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e6935edd2d..7a116152e5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6434,6 +6434,30 @@ draw member forces, nodal forces/displacements, various boundary conditions,
internal force distributions, etc.")
(license license:gpl3+)))
+(define-public texlive-struktex
+ (package
+ (name "texlive-struktex")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/struktex/"
+ "source/latex/struktex/"
+ "tex/latex/struktex/")
+ (base32
+ "05bvzxrqwiw9jcq1dvvwf6ss1207qygg3iqdlfd0yjv0y7rdjvvf")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/struktex")
+ (synopsis "Draw Nassi-Shneiderman charts")
+ (description
+ "Nassi-Shneiderman charts are a well known tool to describe an algorithm
+in a graphical way. The package offers some macros for generating those
+charts in a LaTeX document. The package provides the most important elements
+of a Nassi-Shneiderman charts, including processing blocks, loops, mapping
+conventions for alternatives, etc. The charts are drawn using the
+@code{picture} environment (using @code{pict2e} for preference).")
+ (license license:lppl1.2+)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")