summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-03-02 10:37:28 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-02 10:55:08 +0000
commit7df09ee0ab3e7962ef27859ce87e06a323059284 (patch)
treed81334f742ddcb9a1ee63961ca6410922980af1c /gnu/packages/tex.scm
parent2ac51ec99b58b50c08ba719a8c7e9dba0330b065 (diff)
parentaf95f2d8f98eb2c8c64954bb2fd0b70838899174 (diff)
Merge remote-tracking branch 'savannah/master' into core-updates
Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm128
1 files changed, 113 insertions, 15 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3d8c71e62f..7172944c70 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1224,7 +1224,7 @@ support (for use with a variety of encodings) is provided.")
(base32
"0yyk0dr4yms82mwy4dc03zf5igyhgcb65icdah042rk23rlpxygv")
#:trivial? #t))
- (home-page "http://www.gust.org.pl/projects/e-foundry/latin-modern/")
+ (home-page "https://www.gust.org.pl/projects/e-foundry/latin-modern/")
(synopsis "Latin Modern family of fonts")
(description "The Latin Modern fonts are derived from the famous Computer
Modern fonts designed by Donald E. Knuth and described in Volume E of his
@@ -1245,7 +1245,7 @@ Computers & Typesetting series.")
(base32
"0gqdk8x3r1iz4n8j6r3pcqbwalxvkihayvmjfq4iv6hwb0pvys8z")
#:trivial? #t))
- (home-page "http://www.gust.org.pl/projects/e-foundry/latin-modern")
+ (home-page "https://www.gust.org.pl/projects/e-foundry/latin-modern")
(synopsis "OpenType maths fonts for Latin Modern")
(description "Latin Modern Math is a maths companion for the Latin Modern
family of fonts, in OpenType format. For use with LuaLaTeX or XeLaTeX,
@@ -4368,7 +4368,7 @@ polyglossia package rather than Babel.")
"fonts/vf/cs/cs-a35/")
(base32 "1ww5lrqja051fh0ygmfdyy5a6bhwq9k5zv857vwiqf5syvw5djps")
#:trivial? #t))
- (home-page "http://petr.olsak.net/cstex/")
+ (home-page "https://petr.olsak.net/cstex/")
(synopsis "Czech/Slovak-tuned Computer Modern fonts")
(description "This package provides Czech/Slovak-tuned Computer Modern
fonts in the Metafont format; Type 1 format versions (csfonts-t1) are also
@@ -4384,7 +4384,7 @@ available.")
(list "tex/csplain/base/")
(base32 "0cgrwc8lgf2x2hq6bb4kqxw597card985zdd9ipn7k98mmwrxhz3")
#:trivial? #t))
- (home-page "http://petr.olsak.net/csplain-e.html")
+ (home-page "https://petr.olsak.net/csplain-e.html")
(synopsis "Plain TeX multilanguage support")
(description "CSplain is a small extension of basic Plain TeX macros from
which the formats @code{csplain} and @code{pdfcsplain} can be generated. It
@@ -5195,6 +5195,7 @@ corresponding italics: light, regular, medium, bold, ...")
(base32
"157pplavvm2z97b3jl4x41w11k6q9wgy074mfg0dwmsx5lm328jy"))))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-catchfile))
(arguments '(#:tex-directory "latex/ifplatform"))
(home-page "https://www.ctan.org/pkg/ifplatform")
(synopsis "Conditionals to test which platform is being used")
@@ -5589,6 +5590,26 @@ capabilities of longtable and tabularx; an environment for including plain TeX
in LaTeX documents; a jiffy to create slashed characters for physicists.")
(license license:lppl)))
+(define-public texlive-catchfile
+ (let ((template (simple-texlive-package
+ "texlive-catchfile"
+ (list "/doc/latex/catchfile/"
+ "/source/latex/catchfile/"
+ "/tex/generic/catchfile/")
+ (base32
+ "1dpxy64hs0bjp8d2dmikflc995vazf7fi6z92w51fnj2fidgl8gx"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "latex/catchfile")))
+ (home-page "https://ctan.org/macros/latex/contrib/catchfile")
+ (synopsis "Catch an external file into a macro")
+ (description
+ "Catchfile catches the contents of a file and puts it in a macro.")
+ (license license:lppl1.3+))))
+
(define-public texlive-doi
(package
(inherit (simple-texlive-package
@@ -8578,7 +8599,7 @@ values (strings, macros, or numbers) pasted together.")
("perl-file-which" ,perl-file-which)
("perl-test-more" ,perl-test-most) ; FIXME: "more" would be sufficient
("perl-test-differences" ,perl-test-differences)))
- (home-page "http://biblatex-biber.sourceforge.net/")
+ (home-page "https://biblatex-biber.sourceforge.net/")
(synopsis "Backend for the BibLaTeX citation management tool")
(description "Biber is a BibTeX replacement for users of biblatex. Among
other things it comes with full Unicode support.")
@@ -8651,7 +8672,7 @@ PDF documents.")
(list poppler-qt5 qtbase-5 qtscript zlib))
(native-inputs
(list pkg-config))
- (home-page "http://www.xm1math.net/texmaker/")
+ (home-page "https://www.xm1math.net/texmaker/")
(synopsis "LaTeX editor")
(description "Texmaker is a program that integrates many tools needed to
develop documents with LaTeX, in a single application.")
@@ -10673,6 +10694,37 @@ various fonts are provided. An alternative package
the bundle.")
(license license:lppl1.3c))))
+(define-public texlive-minted
+ (let ((template (simple-texlive-package
+ "texlive-minted"
+ (list "/doc/latex/minted/"
+ "/source/latex/minted/"
+ "/tex/latex/minted/")
+ (base32
+ "13cjsjb3b04n9arwp46ayk8fcicylxq5g1864cpxl1lxjxh1yi0l"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "latex/minted")))
+ (propagated-inputs (list python-pygments
+ texlive-etoolbox
+ texlive-fancyvrb
+ texlive-fvextra
+ texlive-latex-float
+ texlive-latex-framed
+ texlive-latex-ifplatform
+ texlive-latex-newfloat
+ texlive-lineno
+ texlive-xstring))
+ (home-page "https://ctan.org/pkg/minted")
+ (synopsis "Highlight source code in LaTeX documents")
+ (description "This package facilitates expressive syntax highlighting in
+LaTeX using the Pygments library. This package also provides options to
+customize the highlighted source code output using fancyvrb and fvextra.")
+ (license license:lppl1.3+))))
+
(define-public texlive-caption
(let ((template (simple-texlive-package
"texlive-caption"
@@ -11842,6 +11894,28 @@ span the full width of a page; it improves upon floatfig, and allows
tables and figures to be set left/right or alternating on even/odd pages.")
(license license:lppl1.3+)))
+(define-public texlive-fvextra
+ (let ((template (simple-texlive-package
+ "texlive-fvextra"
+ (list "/doc/latex/fvextra/"
+ "/source/latex/fvextra/"
+ "/tex/latex/fvextra/")
+ (base32
+ "0nawx1fh55yhqspy5jgss2qmwpqmikfrg7628smk931rph9nq0aa"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "latex/fvextra")))
+ (home-page "https://ctan.org/macros/latex/contrib/fvextra")
+ (synopsis "Extensions and patches for fancyvrb")
+ (description
+ "This package provides several extensions to fancyvrb, including
+automatic line breaking and improved math mode. It also patches some fancyvrb
+internals.")
+ (license license:lppl1.3+))))
+
(define-public bibtool
(package
(name "bibtool")
@@ -11888,7 +11962,7 @@ and selecting references used in a publication.")
texlive-endnotes
texlive-etoolbox
texlive-fancyhdr
- texlive-generic-xstring
+ texlive-xstring
texlive-graphics
texlive-latex-draftwatermark
texlive-latex-float
@@ -12188,6 +12262,8 @@ Polish of standard ``LaTeX names''.")
"tex/latex/mdframed/")
(base32 "1i5rm946wg43rjckxlfhx79zfx5cgd3bxk71206hd1dqkrgpdpa8")
#:trivial? #t))
+ (propagated-inputs (list texlive-latex-needspace
+ texlive-zref))
(home-page "https://ctan.org/pkg/mdframed")
(synopsis "Framed environments that can split at page boundaries")
(description
@@ -12682,16 +12758,34 @@ which the command @code{\\tab} advances typesetting position to the next
defined ``tab stop''.")
(license license:lppl1.3+)))
-(define-public texlive-generic-soul
+(define-public texlive-soul
(let ((template (simple-texlive-package
- "texlive-generic-soul"
- (list "/doc/generic/soul/"
- "/tex/generic/soul/")
+ "texlive-soul"
+ (list "doc/generic/soul/"
+ "source/generic/soul/"
+ "tex/generic/soul/")
(base32
- "11jdgvfpcv10y5j898495lf29k2m03x39v9jzb4v79w4cgxcmfps")
- #:trivial? #t)))
+ "0ikipdswzsafi4rr6q9xh3hkxk2n2683ym1879qcax41xs6cizdl"))))
(package
(inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t) "generic/soul")
+ ((#:build-targets _ '()) '(list "soul.ins"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/generic/soul/")))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
(home-page "http://www.ctan.org/pkg/soul")
(synopsis "Hyphenation for letterspacing, underlining, and more")
(description
@@ -12703,9 +12797,11 @@ syllable. The package itself does not support UTF-8 input in ordinary
(PDF)LaTeX; some UTF-8 support is offered by package @code{soulutf8}.")
(license license:lppl))))
-(define-public texlive-generic-xstring
+(define-deprecated-package texlive-generic-soul texlive-soul)
+
+(define-public texlive-xstring
(let ((template (simple-texlive-package
- "texlive-generic-xstring"
+ "texlive-xstring"
(list "/doc/generic/xstring/"
"/tex/generic/xstring/")
(base32
@@ -12724,6 +12820,8 @@ recurrences of, a substring. The package works equally in Plain TeX and LaTeX
(expandable) macros.")
(license license:lppl1.3c))))
+(define-deprecated texlive-generic-xstring texlive-xstring)
+
(define-public texlive-substr
(package
(inherit (simple-texlive-package