summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:53:10 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:31 +0200
commit9dbc4e34a1507c768e2f3cb57e6082c70024ae4d (patch)
tree7b01e13043f41d6d5cb9e9dc97468997c192673d /gnu/packages/tex.scm
parent72cae574170e047c85ca3f1d4f699ee0ee55a07f (diff)
gnu: Add texlive-sympytexpackage.
* gnu/packages/tex.scm (texlive-sympytexpackage): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 028610abb1..67577bb233 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6554,6 +6554,28 @@ syllogisms and syllogistic-like arguments, composed of two premises and
a conclusion.")
(license license:lppl)))
+(define-public texlive-sympytexpackage
+ (package
+ (name "texlive-sympytexpackage")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/sympytexpackage/"
+ "scripts/sympytexpackage/"
+ "source/latex/sympytexpackage/"
+ "tex/latex/sympytexpackage/")
+ (base32
+ "0ph8pldk2f477dm79vf5vrismfy8w1p2m455qfjqm7p704jm1pr3")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/sympytex")
+ (synopsis "Include symbolic computation (using @code{sympy}) in documents")
+ (description
+ "The bundle supports inclusion of symbolic-python (@code{sympy})
+expressions, as well as graphical output from the @code{sympy} plotting
+module (or from Matplotlib).")
+ (license license:gpl2)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")