summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2022-07-28 15:51:36 +0100
committerLudovic Courtès <ludo@gnu.org>2022-08-03 17:43:28 +0200
commitb3f1666dd61df4cbb07d0e3d7ae0876d49ddf916 (patch)
treee9894cd12de00dd2a5991de09540351dcbead874 /gnu/packages/tex.scm
parent212f8e4bbc9dd92bdd526ad7f6f529ea253a0eea (diff)
gnu: Add texlive-everyshi.
* gnu/packages/tex.scm (texlive-everyshi): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ca80405de2..fe90d15124 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11266,3 +11266,26 @@ provides its own hooks to fulfill this task. For newer versions of LaTeX
compatibility reasons. See @code{lthooks-doc.pdf} for instructions how to use
@code{lthooks} instead of @code{everysel}.")
(license license:lppl1.3c)))
+
+(define-public texlive-everyshi
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-everyshi"
+ (list "doc/latex/everyshi/"
+ "source/latex/everyshi/"
+ "tex/latex/everyshi/")
+ (base32 "11y6xazv1nk0m2hzsainjr8ijn5cff04xfccm6a65hzg7ipggraj")
+ #:trivial? #t))
+ (home-page "https://ctan.org/pkg/everyshi")
+ (synopsis "Take action at every @code{\\shipout}")
+ (description
+ "The @code{everyshi} package provides hooks into @code{\\sshipout} called
+@code{\\EveryShipout} and @code{\\AtNextShipout} analogous to
+@code{\\AtBeginDocument}. With the introduction of the LaTeX hook management
+this package became obsolete in 2020 and is only provided for backwards
+compatibility. For current versions of LaTeX it is only mapping the hooks to
+the original @code{everyshi} macros. In case you use an older LaTeX format,
+@code{everyshi} will automatically fall back to its old implementation by
+loading @code{everyshi-2001-05-15}.")
+ (license license:lppl1.3c)))