summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:50:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:25 +0200
commite143f9740d4634af762d36c03350d6c743ec79c3 (patch)
tree6b03366f79a7a8f82ff576eba0a8c15a00f72f0a /gnu/packages/tex.scm
parent5ab8d54fbcf33e821bc72904a5f500230dd75c05 (diff)
gnu: Add texlive-stanli.
* gnu/packages/tex.scm (texlive-stanli): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c6abbb96d0..63cf5932f5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6266,6 +6266,27 @@ can be adjusted with respect to relative position and format, and can be used
in text and math mode.")
(license license:cc-by4.0)))
+(define-public texlive-stanli
+ (package
+ (name "texlive-stanli")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/stanli/" "tex/latex/stanli/")
+ (base32
+ "1kspb85303z642qj3c9b2q3g41p612vshn37j7npf3if2gcyyxbq")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/stanli")
+ (synopsis "TikZ Library for Structural Analysis")
+ (description
+ "STANLI is a STructural ANalysis LIbrary based on PGF/TikZ. Creating new
+assignments and tests, at university, is usually a very time-consuming task,
+especially when this includes drawing graphics. In the field of structural
+engineering, those small structures are a key part for teaching. This package
+permits to create such 2D and 3D structures in a very fast and simple way.")
+ (license (list license:gpl3+ license:lppl1.3+))))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")