summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:48:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:42:24 +0200
commite349ac218070d25a88043fb61ac7b24309e31424 (patch)
tree65b738b033175b77a0e9c142f1bdfcad488014b9 /gnu/packages/tex.scm
parentf8b1191e064a10b0954aaafbce2374149fe24ba1 (diff)
gnu: Add texlive-sistyle.
* gnu/packages/tex.scm (texlive-sistyle): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a49b6b8959..93917541bd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6158,6 +6158,28 @@ coefficients are given row by row in a list of values separated by commas.")
and below expressions.")
(license license:gpl3+)))
+(define-public texlive-sistyle
+ (package
+ (name "texlive-sistyle")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/sistyle/" "source/latex/sistyle/"
+ "tex/latex/sistyle/")
+ (base32
+ "0y53ijyzridia40a5wrpgff74n6shbdh7xbn1n56ciqfgjn4rdq4")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/sistyle")
+ (synopsis "Package to typeset SI units, numbers and angles")
+ (description
+ "This package typesets SI units, numbers and angles according to the ISO
+requirements. Care is taken with font setup and requirements, and language
+customisation is available. Note that this package is (in principle)
+superseded by @code{siunitx}; @code{sistyle} has maintenance-only support,
+now.")
+ (license license:lppl)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")