summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-07-30 21:08:43 -0400
committerLudovic Courtès <ludo@gnu.org>2022-08-05 15:28:03 +0200
commit7279801cff2c7f8a904086850a6ea835df89eb36 (patch)
tree80f55b5fce9a82a76a3ac36dc4765fc9b5270047 /gnu/packages/tex.scm
parent1a1c4e48855af1462d9c72990b1cf0fefbfa26af (diff)
gnu: Add texlive-abstract.
* gnu/packages/tex.scm (texlive-abstract): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fe90d15124..2cd6311b2d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2021 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;; Copyright © 2022 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2022 Fabio Natali <me@fabionatali.com>
+;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11289,3 +11290,40 @@ the original @code{everyshi} macros. In case you use an older LaTeX format,
@code{everyshi} will automatically fall back to its old implementation by
loading @code{everyshi-2001-05-15}.")
(license license:lppl1.3c)))
+
+(define-public texlive-abstract
+ (let ((template (simple-texlive-package
+ "texlive-abstract"
+ '("doc/latex/abstract/"
+ "source/latex/abstract/"
+ "tex/latex/abstract/")
+ (base32
+ "1axm78qgrpml09pkh252g1hsjx9c2w7mbdrm9rdl4yqh5ppwq4y9"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #f)
+ "latex/abstract")
+ ((#:build-targets _ #t)
+ #~(list "abstract.ins"))
+ ((#:phases std-phases)
+ #~(modify-phases #$std-phases
+ (add-after 'unpack 'chdir
+ (lambda args
+ (chdir "source/latex/abstract")))
+ (add-before 'copy-files 'unchdir
+ (lambda args
+ (chdir "../../..")))
+ (add-after 'copy-files 'remove-extra-files
+ (lambda args
+ (delete-file-recursively
+ (string-append #$output
+ "/share/texmf-dist"
+ "/source/latex/abstract/build"))))))))
+ (home-page "https://ctan.org/pkg/abstract")
+ (synopsis "Control the typesetting of the abstract environment")
+ (description "The abstract package gives you control over the typesetting
+of the abstract environment, and in particular provides for a one column
+abstract in a two column paper.")
+ (license license:lppl))))