summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorFabio Natali <me@fabionatali.com>2022-07-16 15:46:18 +0100
committerLudovic Courtès <ludo@gnu.org>2022-08-03 17:43:28 +0200
commitaceb696cb0d701b364514b68dc04de3398b8e5bc (patch)
treeb7ca383ba564ba064fbd68d1c87245164776dfc4 /gnu/packages/tex.scm
parent734805d15d6397dd050c4befbefbd646bd32b7bb (diff)
gnu: Add texlive-ragged2e.
* gnu/packages/tex.scm (texlive-ragged2e): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2f2cb3a697..2d6425773c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11224,3 +11224,23 @@ combine the features of the @code{tabularx} package (auto-sized columns in a
fixed-width table) with those of the @code{longtable} package (multi-page
tables).")
(license license:lppl)))
+
+(define-public texlive-ragged2e
+ (package
+ (inherit
+ (simple-texlive-package
+ "texlive-ragged2e"
+ (list "doc/latex/ragged2e/"
+ "source/latex/ragged2e/"
+ "tex/latex/ragged2e/")
+ (base32 "1cxj5jdgvr3xk1inrb3yzpm3l386jjawgpqiwsz53k6yshb6yfml")
+ #:trivial? #t))
+ (home-page "https://ctan.org/pkg/ragged2e")
+ (synopsis "Alternative versions of \"ragged\"-type commands")
+ (description
+ "The @code{ragged2e} package defines new commands @code{\\Centering}, @code{\\RaggedLeft},
+and @code{\\RaggedRight} and new environments @code{Center}, @code{FlushLeft},
+and @code{FlushRight}, which set ragged text and are easily configurable to
+allow hyphenation (the corresponding commands in LaTeX, all of whose names are
+lower-case, prevent hyphenation altogether).")
+ (license license:lppl1.3c)))