summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:55:14 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:34 +0200
commit3f6c9b70d5a03745e27cb123bbe6ac896a6ba74a (patch)
tree181cd62a85d21b283d89ab5b4b9616441fe9d1b9 /gnu/packages/tex.scm
parent26741f5cfd2e4fd48f890d193a875014d18cf630 (diff)
gnu: Add texlive-letterspacing.
* gnu/packages/tex.scm (texlive-letterspacing): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5fce27bd23..be0bc10c60 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3029,6 +3029,26 @@ documentation and six demo presentations ranging from geometric abstraction to
classic style to silly video game.")
(license license:lppl)))
+(define-public texlive-letterspacing
+ (package
+ (name "texlive-letterspacing")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "tex/generic/letterspacing/")
+ (base32
+ "0ry7rri76dgbrkzr6na2kkh7bn0jpwkhh9b5qw0cl5xwyp81rddg")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/letterspacing")
+ (synopsis "Letter spacing")
+ (description
+ "This package helps spacing out the letters of text; the command is
+@code{\\letterspace<\\hbox modifier>@{<text>@}}: the text is placed in an
+@code{\\hbox} of the specified size, and space is inserted between each glyph
+to make the text fit the box. Note that letterspacing is not ordinarily
+considered acceptable in modern typesetting of English.")
+ (license license:knuth)))
+
(define-public texlive-tex
(package
(name "texlive-tex")