summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <wzelazny@vurv.cz>2022-09-13 14:32:51 +0200
committerLudovic Courtès <ludo@gnu.org>2022-09-26 23:29:37 +0200
commit4d9c9b49812cf2b8ef1da76eb43421fd73b18a72 (patch)
treeeb0c68825ca280a97c938740e81e6599842eabcc /gnu/packages/tex.scm
parent22c6d4dc142b61a218ee46c0181d69eb3f242e75 (diff)
gnu: Add texlive-babel-polish.
* gnu/packages/tex.scm (texlive-babel-polish): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 243093a0a7..2dc052b1a7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11297,6 +11297,33 @@ Danish in @code{babel}. It provides all the necessary macros, definitions and
settings to typeset Danish documents.")
(license license:lppl1.3c+))))
+(define-public texlive-babel-polish
+ (let ((template (simple-texlive-package
+ "texlive-babel-polish"
+ (list "/source/generic/babel-polish/")
+ (base32
+ "1jymxl98mwxmq0yq90mhrr7bq7c613rh1rnhl7l3bih36af55rwr"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "generic/babel-polish")
+ ((#:build-targets _ '())
+ ''("polish.ins")) ; TODO: use dtx and build documentation
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/generic/babel-polish")))))))
+ (home-page "https://www.ctan.org/pkg/babel-polish")
+ (synopsis "Babel support for Polish")
+ (description
+ "This package provides the language definition file for support of
+Polish in @code{babel}. Some shortcuts are defined, as well as translations to
+Polish of standard ``LaTeX names''.")
+ (license license:lppl1.3+))))
+
(define-public texlive-mdframed
(package
(inherit