summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 10:59:31 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-20 11:17:37 +0200
commit92f40b4e5badc18950fad4f4f66fe4f4b0e35aed (patch)
treeeefbfa07f17feb85d2356cd2c25f119688cc4eb0 /gnu/packages/tex.scm
parentc486dde4cac640eace0bc799bae92e8a05565df9 (diff)
gnu: Add texlive-outerhbox.
* gnu/packages/tex.scm (texlive-outerhbox): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d465382e56..f3325e24c9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3275,6 +3275,25 @@ conversion;
@end itemize")
(license license:public-domain)))
+(define-public texlive-outerhbox
+ (package
+ (name "texlive-outerhbox")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "tex/generic/outerhbox/")
+ (base32
+ "1867xhxlbskiysifmwlr10lay8khragzi36fm552cwc4vjz2ybcz")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/outerhbox")
+ (synopsis "Collect horizontal material for contributing to a paragraph")
+ (description
+ "The package provides the @code{\\outerhbox} command, which is similar to
+@code{\\hbox}, except that material is set in outer horizontal mode. This
+prevents TeX from optimising away maths penalties and the like, that are
+needed when the material is @code{\\unhbox}'ed.")
+ (license license:gpl3+)))
+
(define-public texlive-tex
(package
(name "texlive-tex")