summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-11-28 12:26:32 +0100
committerLudovic Courtès <ludo@gnu.org>2022-11-28 12:26:32 +0100
commit459e4f2a4f2b16daded2aaba20edf3fffa4095f3 (patch)
treed1e2ada4dcfde3d3b4119087550c26856b42dbcf /gnu/packages/tex.scm
parenta3264f31df9774ea514e18ed8e7b6bcb44061edc (diff)
parente6bffa99b19fe01067937a4930f1b107bd0ac398 (diff)
Merge commit 'master' into version-1.4.0
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 81f74f17df..a600bcae58 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3993,6 +3993,47 @@ definitions.")
(define-deprecated-package texlive-latex-amsmath texlive-amsmath)
+(define-public texlive-mathdots
+ (let ((template
+ (simple-texlive-package
+ "texlive-mathdots"
+ (list "doc/generic/mathdots/"
+ "source/generic/mathdots/"
+ "tex/generic/mathdots/")
+ (base32"1jaffj343p1chdxs2g7s6lpckvihk0jfw22nw0vmijyjxfiy9yg0"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "generic/mathdots")
+ ((#:build-targets _ '())
+ '(list "mathdots.ins"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/generic/mathdots")))
+ (replace 'copy-files
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append (assoc-ref outputs "out")
+ "/share/texmf-dist/source"))
+ (doc (string-append (assoc-ref outputs "doc")
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (home-page "https://ctan.org/macros/generic/mathdots")
+ (synopsis "Commands to produce dots in math that respect font size")
+ (description
+ "Mathdots redefines @code{\\ddots} and @code{\\vdots}, and defines
+@code{\\iddots}. The dots produced by @code{\\iddots} slant in the opposite
+direction to @code{\\ddots}. All the commands are designed to change size
+appropriately in scripts, as well as in response to LaTeX size changing
+commands. The commands may also be used in plain TeX.")
+ (license license:lppl))))
+
(define-public texlive-amscls
(let ((template (simple-texlive-package
"texlive-amscls"