summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-14 22:36:35 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:47 +0200
commit114a5d85aaa88709ba9c07f1350fdf300876258e (patch)
tree1a4fcd3e970d0e05effdc78ed3961ac3456b4787 /gnu/packages/tex.scm
parent14a87760facdcdfab205f25273ee9e8df33b9c07 (diff)
gnu: Add texlive-lm.
* gnu/packages/tex.scm (texlive-lm): New variable. (texlive-fonts-lm): Deprecate package.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm44
1 files changed, 18 insertions, 26 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 119a1ffbf9..b05406b811 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -802,33 +802,22 @@ originals.")
(define-public texlive-fonts-cm-super
(deprecated-package "texlive-fonts-cm-super" texlive-cm-super))
-(define-public texlive-fonts-lm
+(define-public texlive-lm
(package
- (name "texlive-fonts-lm")
- (version "2.004")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://www.gust.org.pl/projects/e-foundry/"
- "latin-modern/download/lm" version "bas.zip"))
- (sha256
- (base32
- "0z2s253y751m2ci5aw8nq0sf2kyg9hpimv2gyixkch9d07m2b9wp"))))
- (build-system trivial-build-system)
- (arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils))
- (let ((root (string-append (assoc-ref %outputs "out")
- "/share/texmf-dist/")))
- (mkdir-p root)
- (with-directory-excursion root
- (invoke (string-append (assoc-ref %build-inputs "unzip")
- "/bin/unzip")
- (assoc-ref %build-inputs "source")))
- #t))))
- (native-inputs
- `(("unzip" ,unzip)))
+ (inherit (simple-texlive-package
+ "texlive-lm"
+ (list "/doc/fonts/lm/"
+ "/fonts/afm/public/lm/"
+ "/fonts/enc/dvips/lm/"
+ "/fonts/map/dvipdfm/lm/"
+ "/fonts/map/dvips/lm/"
+ "/fonts/opentype/public/lm/"
+ "/fonts/tfm/public/lm/"
+ "/fonts/type1/public/lm/"
+ "/tex/latex/lm/")
+ (base32
+ "0i1hwr8rp0jqyvs4qyplrirscd4w7lsgwsncyv3yzy80bsa56jq5")
+ #:trivial? #t))
(home-page "http://www.gust.org.pl/projects/e-foundry/latin-modern/")
(synopsis "Latin Modern family of fonts")
(description "The Latin Modern fonts are derived from the famous Computer
@@ -839,6 +828,9 @@ Computers & Typesetting series.")
;; additional but not legally binding clause.
(license license:lppl1.3c+)))
+(define-public texlive-fonts-lm
+ (deprecated-package "texlive-fonts-lm" texlive-lm))
+
(define-public texlive-fonts-knuth-lib
(package
(name "texlive-fonts-knuth-lib")