summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-09 00:39:43 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-09 00:39:43 +0100
commitfa5a0625728f5ad74c1cf9b785a519d7b1cc15c8 (patch)
treebb746321938c730f4421c0b5b7f005212dd3e9b3 /gnu/packages/tex.scm
parent359636a40833cee9a5a0a00ffc1b501b432cfb8d (diff)
gnu: texlive-latex-eso-pic: Rename to texlive-eso-pic.
* gnu/packages/tex.scm (texlive-eso-pic): New variable. (texlive-latex-eso-pic): Deprecated alias.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm63
1 files changed, 45 insertions, 18 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b4724b693c..8538a97074 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6340,26 +6340,53 @@ format. LaTeX support, for using these fonts in mathematics, is available via
one of the packages @code{calrsfs} and @code{mathrsfs}.")
(license (license:fsf-free "http://mirrors.ctan.org/fonts/rsfs/README"))))
-(define-public texlive-latex-eso-pic
- (package
- (name "texlive-latex-eso-pic")
- (version (number->string %texlive-revision))
- (source (origin
- (method svn-fetch)
- (uri (texlive-ref "latex" "eso-pic"))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "12f7pbhiav4iz3rra5vq85v9f14h8j1ybi42kvnkzgjsay87p7gf"))))
- (build-system texlive-build-system)
- (arguments '(#:tex-directory "latex/eso-pic"))
- (home-page "https://www.ctan.org/pkg/eso-pic")
- (synopsis "Add picture commands (or backgrounds) to every page")
- (description
- "The package adds one or more user commands to LaTeX's @code{shipout}
+(define-public texlive-eso-pic
+ (let ((template (simple-texlive-package
+ "texlive-eso-pic"
+ (list "doc/latex/eso-pic/"
+ "source/latex/eso-pic/"
+ "tex/latex/eso-pic/")
+ (base32
+ "05bqm4x209wji0q6xk1jrjp0nzqafp44dlq30hlpcagrggjb3d9s"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "latex/eso-pic")
+ ((#:build-targets _ '())
+ #~(list "eso-pic.ins"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/latex/eso-pic")))
+ (replace 'copy-files
+ (lambda _
+ (let ((origin #$(package-source this-package))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc)
+ ;; This file is not generated.
+ (install-file
+ (string-append origin
+ "/tex/latex/eso-pic/showframe.sty")
+ (string-append
+ #$output
+ "/share/texmf-dist/tex/latex/eso-pic")))))))))
+ (home-page "https://ctan.org/macros/latex/contrib/eso-pic")
+ (synopsis "Add picture commands (or backgrounds) to every page")
+ (description
+ "The package adds one or more user commands to LaTeX's @code{shipout}
routine, which may be used to place the output at fixed positions. The
@code{grid} option may be used to find the correct places.")
- (license license:lppl1.3+)))
+ (license license:lppl1.3+))))
+
+(define-deprecated-package texlive-latex-eso-pic texlive-eso-pic)
(define-public texlive-latex-eepic
(package