summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-23 22:15:51 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-27 09:48:43 +0100
commit253cdd6c1464c944be2418ee9161f5f5b57e0eee (patch)
tree4277bb63c3e6533761bdb3f508cfce0b7acfad86 /gnu/packages/tex.scm
parentd400068085ed3cf1a0cb956e25812033a97b7b2c (diff)
gnu: Add biber-2.5.
* gnu/packages/tex.scm (biber-2.5): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e950944587..7c84ed7194 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -508,6 +508,32 @@ values (strings, macros, or numbers) pasted together.")
other things it comes with full Unicode support.")
(license license:artistic2.0)))
+;; Our version of texlive comes with biblatex 3.4, which is only compatible
+;; with biber 2.5 according to the compatibility matrix in the biber
+;; documentation.
+(define-public biber-2.5
+ (package (inherit biber)
+ (name "biber")
+ (version "2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/plk/biber/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "163sd343wkrzwnvj2003m2j0kz517jmjr4savw6f8bjxhj8fdrqv"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments biber)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'check 'delete-failing-test
+ (lambda _
+ (delete-file "t/sort-order.t")
+ #t))))))
+ (inputs
+ `(("perl-date-simple" ,perl-date-simple)
+ ,@(package-inputs biber)))))
(define-public rubber
(package