summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2023-02-20 16:05:02 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-23 15:25:40 +0100
commit08e46c300195cdf7744b5382227fee181882acf1 (patch)
tree6d3e8fc2b957a886364748a0275e45c307f69806 /gnu/packages/tex.scm
parent7a01586afe9b65acc0a298b699a66fb187dd7b4f (diff)
gnu: Add texlive-fvextra.
* gnu/packages/tex.scm (texlive-fvextra): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bf4a50973b..6aef6905a6 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11173,6 +11173,28 @@ span the full width of a page; it improves upon floatfig, and allows
tables and figures to be set left/right or alternating on even/odd pages.")
(license license:lppl1.3+)))
+(define-public texlive-fvextra
+ (let ((template (simple-texlive-package
+ "texlive-fvextra"
+ (list "/doc/latex/fvextra/"
+ "/source/latex/fvextra/"
+ "/tex/latex/fvextra/")
+ (base32
+ "0nawx1fh55yhqspy5jgss2qmwpqmikfrg7628smk931rph9nq0aa"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t)
+ "latex/fvextra")))
+ (home-page "https://ctan.org/macros/latex/contrib/fvextra")
+ (synopsis "Extensions and patches for fancyvrb")
+ (description
+ "This package provides several extensions to fancyvrb, including
+automatic line breaking and improved math mode. It also patches some fancyvrb
+internals.")
+ (license license:lppl1.3+))))
+
(define-public bibtool
(package
(name "bibtool")