summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorYarl Baudig <yarl-baudig@mailoo.org>2022-11-21 15:16:27 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-21 23:20:45 +0100
commit437718442ca758a3857702cecfe5c80aa5df272b (patch)
tree6441271f3dd6dc6696769a97f57802f0996ee625 /gnu/packages/tex.scm
parent84100023e23045be2735a6b53f26b2a3c3a1f606 (diff)
gnu: Add texlive-mathdots.
* gnu/packages/tex.scm (texlive-mathdots): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 81f74f17df..a600bcae58 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3993,6 +3993,47 @@ definitions.")
(define-deprecated-package texlive-latex-amsmath texlive-amsmath)
+(define-public texlive-mathdots
+ (let ((template
+ (simple-texlive-package
+ "texlive-mathdots"
+ (list "doc/generic/mathdots/"
+ "source/generic/mathdots/"
+ "tex/generic/mathdots/")
+ (base32"1jaffj343p1chdxs2g7s6lpckvihk0jfw22nw0vmijyjxfiy9yg0"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "generic/mathdots")
+ ((#:build-targets _ '())
+ '(list "mathdots.ins"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/generic/mathdots")))
+ (replace 'copy-files
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append (assoc-ref outputs "out")
+ "/share/texmf-dist/source"))
+ (doc (string-append (assoc-ref outputs "doc")
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (home-page "https://ctan.org/macros/generic/mathdots")
+ (synopsis "Commands to produce dots in math that respect font size")
+ (description
+ "Mathdots redefines @code{\\ddots} and @code{\\vdots}, and defines
+@code{\\iddots}. The dots produced by @code{\\iddots} slant in the opposite
+direction to @code{\\ddots}. All the commands are designed to change size
+appropriately in scripts, as well as in response to LaTeX size changing
+commands. The commands may also be used in plain TeX.")
+ (license license:lppl))))
+
(define-public texlive-amscls
(let ((template (simple-texlive-package
"texlive-amscls"