summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2023-03-18 14:02:15 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-24 09:22:24 +0100
commit5bed6d6846b0ae1e0cb8f6f52ee4bbf8efe72454 (patch)
treed047265cf384d04457e690c56d2b60c6e205e3e0 /gnu/packages/tex.scm
parent4742ea59cb7b6ea3592e4ca6cf8b4fad5611b709 (diff)
gnu: Add texlive-ddphonism.
* gnu/packages/tex.scm (texlive-ddphonism): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1ce5b2ada8..40accf642d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5396,6 +5396,31 @@ in LaTeX documents; a jiffy to create slashed characters for physicists.")
"Catchfile catches the contents of a file and puts it in a macro.")
(license license:lppl1.3+))))
+(define-public texlive-ddphonism
+ (package
+ (inherit (simple-texlive-package
+ "texlive-ddphonism"
+ (list "doc/latex/ddphonism/"
+ "tex/latex/ddphonism/")
+ (base32 "1p02ai76nnh6042pnmqv4n30z6yxsvyyk2nb9jk7xlyyc87zzbdd")
+ #:trivial? #t))
+ (propagated-inputs
+ (list texlive-etoolbox
+ texlive-hyperref
+ texlive-latex-l3packages
+ texlive-listings
+ texlive-pgf
+ texlive-latex-tools
+ texlive-xstring))
+ (home-page "https://www.ctan.org/pkg/ddphonism")
+ (synopsis "Dodecaphonic diagrams for LaTeX")
+ (description
+ "This is a music-related package which is focused on notation from the
+twelve-tone system, also called dodecaphonism. It provides LaTeX algorithms
+that produce typical dodecaphonic notation based off a musical series, or row
+sequence, of variable length.")
+ (license license:lppl1.3c)))
+
(define-public texlive-doi
(package
(inherit (simple-texlive-package