summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-08 11:55:37 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-01-08 12:20:51 +0100
commit6ad0fa893d6ce6183b50eacc6ab53fd07223d49f (patch)
treeda87c1fcb41ab478d9b4916cdd3f74554de0fbe8 /gnu/packages/tex.scm
parente09f3cf9b9acf2c8daf1f9f510e288d86b25d282 (diff)
gnu: lyx: Improve package style.
* gnu/packages/tex.scm (lyx)[source]<snippet>: Remove trailing #T. [arguments]<#phases>: Use SEARCH-INPUT-FILE. [propagated-inputs]: Remove input label.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ba6bb4357a..83a850c0b4 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8330,8 +8330,7 @@ and Karl Berry.")
(modules '((guix build utils)))
(snippet
'(begin
- (delete-file-recursively "3rdparty")
- #t))))
+ (delete-file-recursively "3rdparty")))))
(build-system qt-build-system)
(arguments
(list #:configure-flags
@@ -8352,8 +8351,8 @@ and Karl Berry.")
"src/support/filetools.cpp")
(("\"python ")
(string-append "\""
- (assoc-ref inputs "python")
- "/bin/python3 ")))))
+ (search-input-file inputs "/bin/python3")
+ " ")))))
(add-after 'unpack 'add-missing-test-file
(lambda _
;; Create missing file that would cause tests to fail.
@@ -8369,7 +8368,7 @@ and Karl Berry.")
qtsvg-5
zlib))
(propagated-inputs
- `(("texlive" ,(texlive-updmap.cfg (list texlive-fonts-ec)))))
+ (list (texlive-updmap.cfg (list texlive-fonts-ec))))
(native-inputs
(list python pkg-config))
(home-page "https://www.lyx.org/")