summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-29 21:00:40 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-03-29 21:07:39 +0200
commit853bffb38882fb64932712426c62cbdd43e6978d (patch)
treef2347c4b21a0ab62692176f6ed31d939112482ac /gnu/packages/tex.scm
parent3eb309b4d485e4f9849db20b4cc2c1920f8db620 (diff)
gnu: Add texlive-firstaid.
* gnu/packages/tex.scm (texlive-firstaid): New variable.
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index fed9c77aed..dc202ab410 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5063,6 +5063,44 @@ corresponding italics: light, regular, medium, bold, ...")
(license (list license:lppl
license:silofl1.1))))
+(define-public texlive-firstaid
+ (let ((template (simple-texlive-package
+ "texlive-firstaid"
+ (list "/doc/latex/firstaid/"
+ "/source/latex/firstaid/"
+ "/tex/latex/firstaid/")
+ (base32
+ "1ahn47kz8a2qdmzdfdgjanf6h5bn8f2rzp1zvwgjpk1plcix8k90"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t) "tex/latex/firstaid")
+ ((#:build-targets _ '()) '(list "firstaid.ins"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/firstaid/")))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (home-page "https://ctan.org/macros/latex/required/firstaid")
+ (synopsis
+ "First aid for external LaTeX files and packages that need updating")
+ (description
+ "This package contains some first aid for LaTeX packages or classes
+that require updates because of internal changes to the LaTeX kernel that are
+not yet reflected in the package's or class's code. The file
+@file{latex2e-first-aid-for-external-files.ltx} provided by this package is
+meant to be loaded during format generation and not by the user.")
+ (license license:lppl1.3c))))
+
(define-public texlive-latex-ifplatform
(package
(name "texlive-latex-ifplatform")