summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-03-20 18:21:47 +0100
committerAndreas Enge <andreas@enge.fr>2023-03-20 18:49:06 +0100
commitccb62d8feb50e2859d7c41429a9e3d9e0fe30bfe (patch)
tree4ab573cee33f277828ad553a22579175b1dda22d /gnu/packages/tex.scm
parent098bd280f82350073e8280e37d56a14162eed09c (diff)
parentf80215c7c4ae5ea0c316f4766e6c05ae4218ede3 (diff)
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7172944c70..7abf7f93da 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3702,6 +3702,50 @@ files have changed. It is based on MD5 checksum, provided by pdfTeX.")
(define-deprecated-package texlive-latex-rerunfilecheck texlive-rerunfilecheck)
+(define-public texlive-onedown
+ (let ((template
+ (simple-texlive-package
+ "texlive-onedown"
+ (list "doc/latex/onedown/"
+ "source/latex/onedown/"
+ "tex/latex/onedown/")
+ (base32
+ "04ih7i4v96ggwk4k1mpfx3dzcpi2siqablv93wryg7dk4cks5wkl"))))
+ (package
+ (inherit template)
+ (outputs '("doc" "out"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ #t) "latex/onedown")
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "source/latex/onedown/")))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (texmf (string-append #$output "/share/texmf-dist"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (for-each
+ (lambda (directory)
+ (copy-recursively (string-append origin directory)
+ (string-append texmf directory)))
+ '("/source" "/tex/latex/onedown"))
+ (copy-recursively (string-append origin "/doc")
+ doc))))))))
+ (home-page "https://ctan.org/pkg/onedown")
+ (synopsis "Typeset bridge diagrams")
+ (description
+ "This is a comprehensive package to draw all sorts of bridge diagrams,
+including hands, bidding tables, trick tables, and expert quizzes.
+
+It works for all font sizes. Different fonts for hands, bidding diagrams and
+compass are possible. It also provides annotations to card and bidding
+diagrams, automated check on consistency of suit and hands, and multilingual
+output of bridge terms.")
+ (license license:lppl1.3+))))
+
(define-public texlive-tools
(let ((template (simple-texlive-package
"texlive-tools"