summaryrefslogtreecommitdiff
path: root/gnu/packages/tex.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2023-03-29 15:57:31 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-03-30 12:19:49 +0200
commitf3baa5da06159853ba63c5e666cfc32bb41b0c7c (patch)
tree13700a8534163da0d49c4ad1ed125e3ad3e4769a /gnu/packages/tex.scm
parent9a180b905ee5cb7f2c09ecaf33065763dd254b27 (diff)
gnu: Add texlive-nth.
* gnu/packages/tex.scm (texlive-nth): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/tex.scm')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 087043b06c..60b1892d29 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2022 Fabio Natali <me@fabionatali.com>
;;; Copyright © 2022 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2023 Thomas Albers Raviola <thomas@thomaslabs.org>
+;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11354,6 +11355,24 @@ family and SGML-based languages. Xindy is highly configurable, both in markup
terms and in terms of the collating order of the text being processed.")
(license license:gpl2+)))
+(define-public texlive-nth
+ (package
+ (inherit (simple-texlive-package
+ "texlive-nth"
+ (list "tex/generic/nth/")
+ (base32
+ "0716sd99xjdkplm7jdmg4lx8lpfnnx6mxjp1l1sp2bfqcg73p4hm")
+ #:trivial? #t))
+ (home-page "https://ctan.org/macros/generic/misc/nth.sty")
+ (synopsis "Generate English ordinal numbers")
+ (description
+ "The command @code{\\nth{<number>}} generates English ordinal numbers of
+the form 1st, 2nd, 3rd, 4th, etc. LaTeX package options may specify that the
+ordinal mark be superscripted, and that negative numbers may be treated; Plain
+TeX users have no access to package options, so need to redefine macros for
+these changes.")
+ (license license:public-domain)))
+
(define-public texlive-fmtcount
(package
(inherit (simple-texlive-package