summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorSughosha <sughosha@proton.me>2022-09-22 06:23:13 +0000
committerChristopher Baines <mail@cbaines.net>2022-10-16 18:09:56 +0100
commitfc68b97db12b34dec558fde73d651aa0d3bbd446 (patch)
treec19fe0103a9e283ff3bbd96a7811c7ede40982c6 /gnu/packages/text-editors.scm
parent8488fa5df369ef53ba587c052417fbbfc078e58e (diff)
gnu: Add textpieces.
* gnu/packages/text-editors.scm (textpieces): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 40d6d28b55..dacd2ef80d 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -65,6 +65,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages graphics)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages haskell-xyz)
@@ -899,6 +900,64 @@ Octave. TeXmacs is completely extensible via Guile.")
(license license:gpl3+)
(home-page "https://www.texmacs.org/tmweb/home/welcome.en.html")))
+(define-public textpieces
+ (package
+ (name "textpieces")
+ (version "3.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/liferooter/textpieces")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14zq2c7js80m4cq8wpdb3kyz5sw96l8znbz027w8s94gqhm632ff"))))
+ (arguments
+ '(;; The test suite fails to validate appstream file due to lack of
+ ;; network access
+ #:tests? #f
+ #:glib-or-gtk? #t))
+ (build-system meson-build-system)
+ (native-inputs
+ (list pkg-config
+ vala
+ desktop-file-utils
+ appstream-glib
+ gettext-minimal
+ blueprint-compiler
+ `(,glib "bin")
+ `(,gtk "bin")))
+ (inputs
+ (list json-glib
+ libadwaita
+ libgee
+ python
+ python-pygobject
+ python-pyyaml
+ gtk
+ gtksourceview))
+ (home-page "https://github.com/liferooter/textpieces")
+ (synopsis "Quick text processor")
+ (description
+ "Text Pieces tool for quick text transformations such as checksums,
+encoding, decoding and so on.
+
+The basic features of Text Pieces are:
+@itemize
+@item Base64 encoding and decoding
+@item SHA-1, SHA-2 and MD5 checksums
+@item Prettify and minify JSON
+@item Covert JSON to YAML and vice versa
+@item Count lines, symbols and words
+@item Escape and unescape string, URL and HTML
+@item Remove leading and trailing whitespaces
+@item Sort and reverse sort lines
+@item Reverse lines and whole text
+@item You can write your own scripts and create custom tools
+@end itemize")
+ (license license:gpl3)))
+
(define-public scintilla
(package
(name "scintilla")