summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-01 23:35:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-01 23:40:04 +0200
commit9e03ddc5175a09f408bdca91ea5ccecdfd8fb9af (patch)
tree041e44fcc84a6f86b86b367db7a353f476846589 /gnu/packages/text-editors.scm
parentf3ed5297392fd7fe9cb6fc003824ce34130e80bd (diff)
gnu: geany: Un-unbundle scintilla
* gnu/packages/text-editors.scm (geany)[source]: Do not un-bundle scintilla. [arguments]: Remove phase using our shared library. Use bundled one instead.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm39
1 files changed, 11 insertions, 28 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 0095fcd839..e80e9dcbe5 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -796,17 +796,13 @@ and multiple fonts.")
(package
(name "geany")
(version "1.36")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://download.geany.org/"
- "geany-" version ".tar.bz2"))
- (sha256
- (base32
- "0gnm17cr4rf3pmkf0axz4a0fxwnvp55ji0q0lzy88yqbshyxv14i"))
- (modules '((guix build utils)))
- (snippet '(begin
- (delete-file-recursively "scintilla")
- #t))))
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://download.geany.org/"
+ "geany-" version ".tar.bz2"))
+ (sha256
+ (base32 "0gnm17cr4rf3pmkf0axz4a0fxwnvp55ji0q0lzy88yqbshyxv14i"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
@@ -819,7 +815,10 @@ and multiple fonts.")
("python-docutils" ,python-docutils))) ;for rst2html
(inputs
`(("gtk+" ,gtk+)
- ("scintilla" ,scintilla)))
+ ;; FIXME: Geany bundles a 3.X release of Scintilla. It is not
+ ;; currently possible to replace it with our Scintilla package.
+ ;; ("scintilla" ,scintilla)
+ ))
(arguments
`(#:imported-modules ((guix build glib-or-gtk-build-system)
,@%gnu-build-system-modules)
@@ -828,22 +827,6 @@ and multiple fonts.")
(guix build utils))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'use-scintilla-shared-library
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "configure.ac"
- (("scintilla/Makefile") "")
- (("scintilla/include/Makefile") ""))
- (substitute* "Makefile.am"
- (("scintilla ") ""))
- (substitute* "src/Makefile.am"
- (("\\$\\(top_builddir\\)/scintilla/libscintilla.la") "")
- (("geany_LDFLAGS =" all) (string-append all " -lscintilla")))
- (substitute* "doc/Makefile.am"
- (("\\$\\(INSTALL_DATA\\) \\$\\(top_srcdir\\)/scintilla/License.txt \\$\\(DOCDIR\\)/ScintillaLicense.txt") ""))
- (substitute* "tests/Makefile.am"
- (("AM_LDFLAGS =" all) (string-append all " -lscintilla")))
- (for-each delete-file (list "autogen.sh" "configure" "Makefile.in"))
- #t))
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(home-page "https://www.geany.org")