summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-09-01 04:36:20 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-09-01 04:44:35 +0200
commit7395ea0de42712414402a1b230763799729d4e31 (patch)
tree315ac26049585e37e1336fd1fc31a15962dce3f3 /gnu/packages/text-editors.scm
parent056175769f85320e0e17592eef150f4e7d46dedb (diff)
gnu: editorconfig-core-c: Update to 0.12.4.
* gnu/packages/text-editors.scm (editorconfig-core-c): Update to 0.12.4.
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 22cdbfc704..e0f07832f2 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -709,7 +709,7 @@ in plain text file format.")
(define-public editorconfig-core-c
(package
(name "editorconfig-core-c")
- (version "0.12.3")
+ (version "0.12.4")
(source
(origin
(method git-fetch)
@@ -718,8 +718,7 @@ in plain text file format.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32
- "0jkc69r4jwn4rih6h6cqvgljjc3ff49cxj8286mi515aczr48cm1"))))
+ (base32 "1311fhh2jfsja2hhk3nwb6nijlq03jw8dk35cwbrac0p9jvy03jx"))))
(build-system cmake-build-system)
(arguments
'(#:phases
@@ -730,15 +729,16 @@ in plain text file format.")
(copy-recursively tests "tests"))
#t)))))
(native-inputs
- `(("tests" ,(origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/editorconfig/editorconfig-core-test")
- (commit "6ea1d8ece62cac9cf72c79dce4879b046abe1fe7"))) ; matches version
- (file-name (git-file-name "editorconfig-core-test" version))
- (sha256
- (base32
- "1sf6910idnd4bgzbj8w8f9ldsbkaqa0lh6syymwy3hfqda63acj7"))))))
+ `(("tests"
+ ,(origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/editorconfig/editorconfig-core-test")
+ ;; The tests submodule commit matching this package's version.
+ (commit "48610d43b7455af12195473377f93c4ceea654f5")))
+ (file-name (git-file-name "editorconfig-core-test" version))
+ (sha256
+ (base32 "1s29p4brmcsc3xsww3gk85dg45f1kk3iykh1air3ij0hymf5dyqy"))))))
(inputs
`(("pcre2" ,pcre2)))
(home-page "https://editorconfig.org/")