summaryrefslogtreecommitdiff
path: root/gnu/packages/text-editors.scm
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2022-11-25 01:21:11 +0000
committerAndrew Tropin <andrew@trop.in>2023-02-09 17:36:23 +0400
commitce7d0d689c07a7a6fd11d5d00f0e6c990cb4ee07 (patch)
treef4eab339288e3f899678aab1cada42ebacb3ac37 /gnu/packages/text-editors.scm
parent1a5f5694a7cd4bb19e9de27266e06b80d33d95cd (diff)
gnu: tree-sitter: Move to its own module.
* gnu/packages/text-editors.scm (tree-sitter): Move to ... * gnu/packages/tree-sitter.scm: ... here, a new module. * gnu/packages/vim.scm: Use (gnu packages tree-sitter). * gnu/packages/emacs.scm: Use (gnu packages tree-sitter). * gnu/local.mk (GNU_SYSTEM_MODULES): Register tree-sitter.scm new module. Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages/text-editors.scm')
-rw-r--r--gnu/packages/text-editors.scm52
1 files changed, 0 insertions, 52 deletions
diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index f9330008e7..9c70b5c758 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -73,7 +73,6 @@
#:use-module (gnu packages guile)
#:use-module (gnu packages haskell-xyz)
#:use-module (gnu packages hunspell)
- #:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages llvm)
@@ -1256,57 +1255,6 @@ similar to vi/ex.")
FreeDOS as a functional clone of the old MS-DOS program edlin.")
(license license:gpl2+)))
-(define-public tree-sitter
- (package
- (name "tree-sitter")
- (version "0.20.6")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tree-sitter/tree-sitter")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1z20518snyg0zp75qgs5bxmzjqws4dd19vnp6sya494za3qp5b6d"))
- (modules '((guix build utils)))
- (snippet '(begin
- ;; Remove bundled ICU parts
- (delete-file-recursively "lib/src/unicode")
- #t))))
- (build-system gnu-build-system)
- (inputs (list icu4c))
- (arguments
- (list #:phases
- '(modify-phases %standard-phases
- (delete 'configure))
- #:tests? #f ; there are no tests for the runtime library
- #:make-flags
- #~(list (string-append "PREFIX="
- #$output)
- (string-append "CC="
- #$(cc-for-target)))))
- (home-page "https://tree-sitter.github.io/tree-sitter/")
- (synopsis "Incremental parsing system for programming tools")
- (description
- "Tree-sitter is a parser generator tool and an incremental parsing
-library. It can build a concrete syntax tree for a source file and efficiently
-update the syntax tree as the source file is edited.
-
-Tree-sitter aims to be:
-
-@itemize
-@item General enough to parse any programming language
-@item Fast enough to parse on every keystroke in a text editor
-@item Robust enough to provide useful results even in the presence of syntax errors
-@item Dependency-free so that the runtime library (which is written in pure C)
-can be embedded in any application
-@end itemize
-
-This package includes the @code{libtree-sitter} runtime library.
-")
- (license license:expat)))
-
(define-public mle
(package
(name "mle")