summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-11-11 17:49:04 +0800
committerMathieu Othacehe <othacehe@gnu.org>2023-11-25 14:47:51 +0100
commitf982e290f04f611d6f23367781c73346b77ea14f (patch)
tree78a98a7c3eeac6fdf2c198e62ec61275ed3f5bee /gnu/packages/textutils.scm
parenta077907226d2f0d1345a661f7b285336ee858c10 (diff)
gnu: nkf: Fix cross-compilation.
* gnu/packages/textutils.scm (nkf): Fix cross-compilation. [arguments]: Use gexp and CC-FOR-TARGET. Change-Id: Idd2cbdd89d4ce2feb484a6005e06f1eba491feea Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 41a34b6c4e..801d8fd8ad 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -27,6 +27,7 @@
;;; Copyright © 2022 Gabriel Wicki <gabriel@erlikon.ch>
;;; Copyright © 2023 Reza Housseini <reza@housseini.me>
;;; Copyright © 2023 Hilton Chain <hako@ultrarare.space>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1289,13 +1290,14 @@ Mainland China, Taiwan, and Hong-Kong.")
"0anw0knr1iy4p9w3d3b3pbwzh1c43p1i2q4c28kw9zviw8kx2rly"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; test for perl module
- #:make-flags (list "CC=gcc" "CFLAGS=-O2 -Wall -pedantic"
- (string-append "prefix=" %output)
- "MKDIR=mkdir -p")
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)))) ; No ./configure script
+ (list #:tests? #f ; test for perl module
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ "CFLAGS=-O2 -Wall -pedantic"
+ (string-append "prefix=" #$output)
+ "MKDIR=mkdir -p")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)))) ; No ./configure script
(home-page "https://ja.osdn.net/projects/nkf/")
(synopsis "Network Kanji Filter")
(description "Nkf is yet another kanji code converter among networks,