summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorWiktor Żelazny <wz@freeshell.de>2023-02-26 16:23:51 +0100
committerLudovic Courtès <ludo@gnu.org>2023-06-08 23:34:08 +0200
commit2fd76ec1a3681dc7ba4b0fb78b18646d1fbf6aea (patch)
tree7ac91b6f95ca940f4929122d8fbad6594d44e232 /gnu/packages/textutils.scm
parent5e0b8d51b87bed97a07f3a7c70cf41c92473fd71 (diff)
gnu: Add python-panflute.
* gnu/packages/textutils.scm (python-panflute): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 24fc689a0a..47f6de3078 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -57,6 +57,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
#:use-module (gnu packages golang)
@@ -69,6 +70,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages python-build)
#:use-module (gnu packages python-check)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
#:use-module (gnu packages ruby)
@@ -1536,3 +1538,30 @@ hackers and programmers by being fast, ignoring VCS directories, letting a user
easily specify file types, match highlighting, Perl-Compatible Regular
Expressions, and being faster to type than grep.")
(license license:artistic2.0)))
+
+(define-public python-panflute
+ (package
+ (name "python-panflute")
+ (version "2.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "panflute" version))
+ (sha256
+ (base32
+ "1jk5b2sp1h4drkjrg2ks77d0ca6j043n2myvacm77nfc93y9vzff"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-click python-pyyaml))
+ (native-inputs (list python-configparser
+ python-coverage
+ python-flake8
+ python-pandocfilters
+ python-pytest
+ python-pytest-cov
+ python-requests))
+ (home-page "http://scorreia.com/software/panflute/")
+ (synopsis "Pythonic Pandoc filters")
+ (description
+ "Panflute is a Python package that makes Pandoc filters fun to
+write. It is a pythonic alternative to John MacFarlane's pandocfilters, from
+which it is heavily inspired.")
+ (license license:bsd-3)))