summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-03-31 23:20:18 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-04-01 00:39:15 +0200
commit1cba1f8ce6f84c4737650401c0eb0473a45f9ff7 (patch)
treea19317812471db31ae2a97844d6cf74e45057466 /gnu/packages/textutils.scm
parent470fa47daa62043607d47cd6fb88a365ccfda1a3 (diff)
gnu: java-rsyntaxtextarea: Install resources.
* gnu/packages/textutils.scm (java-rsyntaxtextarea)[arguments]: Enable tests; install resources. [native-inputs]: Add xorg-server-for-tests. Change-Id: If7c89bc6a38058b9cccd74012fa9b5ba14d560d6
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm28
1 files changed, 20 insertions, 8 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 25de916fcb..4374f59ffa 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
@@ -84,7 +84,8 @@
#:use-module (gnu packages ruby)
#:use-module (gnu packages slang)
#:use-module (gnu packages syncthing)
- #:use-module (gnu packages web))
+ #:use-module (gnu packages web)
+ #:use-module (gnu packages xorg))
(define-public dos2unix
(package
@@ -944,13 +945,24 @@ Filter, list, or split a tar file.
"0dyflzvxq2wvs0rgqfyi5yzzrb6r4bzw2dm8cl304dakxk38ddys"))))
(build-system ant-build-system)
(arguments
- `(;; FIXME: some tests fail because locale resources cannot be found.
- ;; Even when I add them to the class path,
- ;; RSyntaxTextAreaEditorKitDumbCompleteWordActionTest fails.
- #:tests? #f
- #:jar-name "rsyntaxtextarea.jar"))
+ (list
+ #:jar-name "rsyntaxtextarea.jar"
+ #:phases
+ '(modify-phases %standard-phases
+ (add-before 'build 'copy-resources
+ (lambda _
+ (copy-recursively "src/main/resources" "build/classes")))
+ (add-before 'check 'start-xorg-server
+ (lambda _
+ ;; The test suite requires a running X server.
+ (system "Xvfb :1 &")
+ (setenv "DISPLAY" ":1")
+ ;; Prevent irrelevant errors that cause test output mismatches:
+ ;; ‘Fontconfig error: No writable cache directories’
+ (setenv "XDG_CACHE_HOME" (getcwd)))))))
(native-inputs
- (list java-junit java-hamcrest-core))
+ (list java-junit java-hamcrest-core
+ xorg-server-for-tests))
(home-page "https://bobbylight.github.io/RSyntaxTextArea/")
(synopsis "Syntax highlighting text component for Java Swing")
(description "RSyntaxTextArea is a syntax highlighting, code folding text