summaryrefslogtreecommitdiff
path: root/gnu/packages/textutils.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2023-11-11 18:10:37 +0800
committerMathieu Othacehe <othacehe@gnu.org>2023-11-25 14:47:51 +0100
commitb9d4c299893e28b4343cd2fef5f1d25b9d228396 (patch)
treeb925fbdb6da09c8c1d1081aa46b1babf05295541 /gnu/packages/textutils.scm
parentf982e290f04f611d6f23367781c73346b77ea14f (diff)
gnu: odt2txt: Fix cross-compilation.
* gnu/packages/textutils.scm (odt2txt): Fix cross-compilation. [arguments]: Use Gexp and CC-FOR-TARGET. Change-Id: I0a81e601813da0e4b2accaf835e3ea774b742df8 Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/textutils.scm')
-rw-r--r--gnu/packages/textutils.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 801d8fd8ad..ea182b1925 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1130,13 +1130,13 @@ documents into plain text.")
"0im3kzvhxkjlx57w6h13mc9584c74ma1dyymgvpq2y61av3gc35v"))))
(build-system gnu-build-system)
(arguments
- `(#:tests? #f ; no make check
- #:make-flags (list "CC=gcc"
- (string-append "DESTDIR=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- ;; no configure script
- (delete 'configure))))
+ (list #:tests? #f ; no make check
+ #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+ (string-append "DESTDIR=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; no configure script
+ (delete 'configure))))
(inputs
(list zlib))
(home-page "https://github.com/dstosberg/odt2txt/")