summaryrefslogtreecommitdiff
path: root/gnu/packages/time.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-05-10 13:16:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2023-05-10 19:27:07 +0200
commitff3c55bb98c1b9629061af8f8d3848bc6faea064 (patch)
tree886129b9ba911d025228c45d25daf87a655da0ce /gnu/packages/time.scm
parentd071bc5a8246d5688709fe3e2edbd50b39405bd9 (diff)
gnu: Add python-dateutils.
* gnu/packages/time.scm (python-dateutils): New variable.
Diffstat (limited to 'gnu/packages/time.scm')
-rw-r--r--gnu/packages/time.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index 36b561b041..6c1251c1d6 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -233,6 +233,28 @@ datetime module, available in Python 2.3+.")
;; BSD-3 still; but all new code is dual licensed (the user can choose).
(license (list bsd-3 asl2.0))))
+(define-public python-dateutils
+ (package
+ (name "python-dateutils")
+ (version "0.6.12")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "dateutils" version))
+ (sha256
+ (base32
+ "1wg3f3imjq3snvjccv64h5498pqv9xz664xhni7bsh8mnay91p83"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-dateutil python-pytz))
+ (home-page "https://github.com/jmcantrell/python-dateutils")
+ (synopsis "Various utilities for working with date and datetime objects")
+ (description
+ "The main purpose of this package is to provide more complex arithmetic
+operations on dates/times. Heavy use is made of the @code{relativedelta} type
+from the @code{dateutil} library. Much of this package is just a light
+wrapper on top of this with some added features such as range generation and
+business day calculation.")
+ (license bsd-0)))
+
(define-public python-parsedatetime
(package
(name "python-parsedatetime")